[Samba] make fails on Solaris building include/proto.h

Mark Day Mark.Day at mrsc.ucsf.edu
Thu Feb 26 18:39:12 GMT 2004

I'm trying to build Samba 3.0.2 or 3.0.2a on a Solaris system (I've
tried both Solaris 8 and Solaris 9), and after successfully running
configure, the "make" step hangs building proto.h.

Checking the process table, the command that is hanging is:

nawk -v headername=_PROTO_H_ -f script/mkproto.awk

I've tried running this command by hand and it also hangs.  I've
tried the nawk that comes with Solaris and also gawk to no avail.

I've searched the archives, and it looks like one other person had
the identical problem, but unfortunately there is no reply to his
question.  I'm running configure without any option flags, and I've
tried setting my environment to use both Forte C compilers and gcc.
Since I'm not really customizing my build, I guess I feel like this
should be happening to *anyone* trying to build this version on

Does anyone have a suggesion on what to try next?  Can anyone verify that
they've successfully built Samba 3.0.2 on Solaris 8 or 9?

Thank you,
Mark Day

More information about the samba mailing list