[Samba] Re: Virtual network using ssh tunneling on Windows 2K/XP. Please help.

Paul Gardiner samba-list at laser-point.co.uk
Mon Feb 9 08:47:23 GMT 2004

From: "Jérôme Fenal" <jerome.fenal at logicacmg.com>
> Paul Gardiner wrote:
> > Hi,
> > I'm trying to connect to a samba server via an ssh tunnel.  I'm running
> > ssh on my W2K machine.  If I try to connect from another machine that
> > is running an OS called RiscOS and a NetBIOS client called LanMan98
> > then it works perfectly, but if I try to connect from the another Windows
> > machine running XP, or from the W2k machine (uisng loopback), I get
> >
> > "Windows cannot find \\\sharename.  Check the spelling and try again,
> > or try searching for the item by clicking the Start button and then clicking
> > Search."
> >
> > I've found claims on the net of this working.  So what am I doing wrong
> > (other than using Windows in the first place :-) )?
> What are ports that you tunnel with SSH ?
> Did you forget to tunnel 445 ?

I did, but I've added it now, and I'm still getting the same error message.  I
also tried forwarding 138 and 137, with no effect.

Any other ideas?

BTW, to forward 445, I had to stop W2K binding it, but I found info on
a registry change that did the job.


More information about the samba mailing list