[Samba] Problems with Samba PDC and Win2k clients

Arto Jantunen viiru at debian.org
Fri Feb 6 07:46:03 GMT 2004

Last week both win2k hosts on my clients network stopped working. Both
report that they cannot copy files that are in the profile. All other
versions of windows (includes XP, 98 and ME) kept working. Before last
week all machines worked just fine. Here is what samba has to say about

[2004/02/05 08:30:07, 0] rpc_server/srv_netlog.c:api_net_sam_logon(206)
  api_net_sam_logon: Failed to marshall NET_R_SAM_LOGON.
[2004/02/05 08:30:07, 0] rpc_server/srv_pipe.c:api_rpcTNP(1200)
  api_rpcTNP: api_netlog_rpc: NET_SAMLOGON failed.
[2004/02/05 08:30:11, 0]
  domain_client_validate: could not fetch trust account password for
  domain CENSORED

I've tried everything I could think of (including removing the machines
entirely from the domain and adding them back, changing various
configuration parameters (nt acl support = no and some others)), but it
hasn't helped. I'm guessing that this has something to do with a recent
security update for win2k, since both of these machines have automatic
updates enabled. Has anyone else seen this problem? Any ideas?

I am not subscribed to this list so please CC me on any replies.

Arto Jantunen

More information about the samba mailing list