[Samba] winbind confusion

Tim Russell timrussell at rocketmail.com
Thu Feb 5 00:50:49 GMT 2004

Hello there,

I'm having some trouble understanding what's going on with winbind.
I'll apologize in advance for the long post.

Basically, I have a solaris 8 box setup with Samba 3.0.1 and cups
1.1.20. It's going to be a replacement print server for our windows
domain users (NT 4.0 domain and windows 2000 clients). We installed all
our print shares and set them up with "point and print". Everything
works great. I can attach the samba server, connect to printer share
and it will push the print driver down to me. I have matching accounts
on both the windows domain and the solaris 8 server.

Here's the catch. I added the server to the NT domain as a member
server (it will not be allowed to become the PDC or BDC). Then I
configured and started winbind. I ran wbinfo -u and all the users from
the domain and the trusted domains eventually scrolled by. So far so
good. Then, I had another user (a windows domain user) attach to the
samba server and connect to the printer and print a test page. Once
again everything works fine.

Finally, I created a brand new user on the PDC and logged in with it on
a windows 2000 workstation. When attempting to attach to the samba
server it asked for user and password? I thought winbind was supposed
to be querying the PDC every 15 seconds for changes? I'm sure if I run
wbinfo -u it would work again...but I don't want to have to run this
every few minutes or so...What have I missed?


"Human beings act intelligently only after they have
exhausted the alternatives" -- Abba Eban

Do you Yahoo!?
Yahoo! SiteBuilder - Free web site building tool. Try it!

More information about the samba mailing list