[Samba] Back to 3.0.1, Winbind and Solaris 9

Ganguly, Sapan Sapan.Ganguly at thalesgroup.com
Wed Feb 4 09:25:22 GMT 2004


Hello, thanks for the pointers but it still won't work.  I didn't have
pam_winbind.c or pam_winbind.h in the location you mention, I've put them
there now but still no luck.

I ran the crle command, do I have to do anything else to make that change
take effect?

My libnss_winbind.so is only 29k, is that right?  My pam_winbind.so is 27k.


-----Original Message-----
From: Andrew Smith-MAGAZINES [mailto:andrew.smith.06 at bbc.co.uk] 
Sent: 03 February 2004 18:17
To: Ganguly, Sapan ; samba at lists.samba.org
Subject: RE: [Samba] Back to 3.0.1, Winbind and Solaris 9

Hi Sapan,

	I've also got winbind authentication working with my Solaris 9. Just
looked through the truss output from your su command and noticed that your
library search path seems to be /usr/local/lib:/usr/lib. Now I can't think
that should cause a problem but it is the only difference I can see between
my system and yours. Can you try setting the search path as follows and see
if that helps,

crle -C /var/ld/ld.config -l /usr/lib:/usr/local/lib

Also can you confirm you have all of the following files present?

/usr/lib/security/pam_winbind.h /usr/lib/security/pam_winbind.po
/usr/lib/security/pam_winbind.so /usr/lib/libnss_winbind.so
/usr/lib/libnss_winbind.so.1 /usr/lib/libnss_winbind.so.2
/usr/lib/nss_winbind.so.1 /usr/lib/nss_winbind.so.2

cheers Andy.

-----Original Message-----
From: samba-bounces+pubsyssamba=bbc.co.uk at lists.samba.org
[mailto:samba-bounces+pubsyssamba=bbc.co.uk at lists.samba.org]On Behalf Of
Ganguly, Sapan 
Posted At: 29 January 2004 10:27
Posted To: Samba
Conversation: [Samba] Back to 3.0.1, Winbind and Solaris 9
Subject: [Samba] Back to 3.0.1, Winbind and Solaris 9

I've gone back to 3.0.1 to try and get winbind to work with my Solaris 9
machine and NT4 domain.  Everything works except user authentication.  The
wbinfo and getent commands do what they are supposed to.

I've included a truss of 'su - ganguly'

According to pamlog, the user 'ganguly' has been granted access but it is
still hanging.

How do I do a truss of a telnet login?

I'm hoping some one out there is good with Solaris.

Can you help?


BBCi at http://www.bbc.co.uk/

This e-mail (and any attachments) is confidential and may contain personal
views which are not the views of the BBC unless specifically stated. If you
have received it in error, please delete it from your system. Do not use,
copy or disclose the information in any way nor act in reliance on it and
notify the sender immediately. Please note that the BBC monitors e-mails
sent or received. Further communication will signify your consent to this.

More information about the samba mailing list