[Samba] Remote Share Access Problems

Peter Olivia polivia at mindspring.com
Sun Dec 26 10:57:50 GMT 2004

Turns out it was a PATH MTU issue when packets were crossing the router from
one VLAN to the next.  Fixed the MTU issue and everything worked fine.
Should have never doubted Samba ;)



From: Peter Olivia [mailto:polivia at mindspring.com] 
Sent: Wednesday, December 22, 2004 1:44 PM
To: 'samba at lists.samba.org'
Subject: [Samba] Remote Share Access Problems


I have been trying to access home dir shares on my Samba PDC from a windows
2003 server that is on a remote subnet with no success.  I am running SAMBA
3.0.9 as an LDAP PDC (and as of today 3.0.10 to try fix this issue).  On the
server in question, these dirs are local to the server, but I also NFS
export them to other servers.  I can access other shares with identical
uid/gids and permissions on the same server.  But if I try to connect to my
home dirs, it sits forever until it comes back with \\server\share is not
accessible ... the specified network name is no longer available.  If I
create a new file in the accessible shares, it saves it as the correct
uid/gid.  If I move the server to the same subnet as the PDC, all works just
fine.  My first guess was that something was cached on the server that was
causing my grief.  I tried removing any somewhat recent tdb and dat files
that were in /var/cache/samba to no avail.  I finally rebooted to see if I
could make the shares work. Nothing seems to allow access to the existing
dirs.  If I recreate the dirs with identical names, they work.  I just hate
to recreate all the homedirs and migrate data just to have it return again
later on.  Could it be a locking issue?  Any ideas where to turn?

More information about the samba mailing list