[Samba] Samba 3.0.10 ADS setup issue

Jon Starbird jcstar at streamtheory.com
Wed Dec 22 02:27:51 GMT 2004

I am attempting to setup Samba 3.0.10 on a Windows 2000 Active Directory 
domain. The problem I'm having is getting Samba to configure correctly 
to get the Kerberos library.
I've gone through previous posts and have tried doing what others 
suggested but I still keep getting the error of:

"configure: error: libkrb5 is needed for Active Directory support"

The current configure params I'm using are:

"./configure --with-ads=yes --with-krb5=/usr/lib"

I've tried many different path entries, left out the path info with just 
the first option, nothing works I keep getting the exact error. It just 
never can find the Kerberos files.
I've tried installing Kerberos 5 via Pkg_add, I've also downloaded and 
compiled it, this latest attempt is with Heimdal 0.6.3 being complied 
from source.
Here is dump of a find for libkrb5* on the system:


I have pointed the configure param to all of the above, including the 
source ones (I'm getting desperate!).

So please someone help! Let me know if you need more info.

Many thanks in advance.


More information about the samba mailing list