[Samba] RE: Using samba on two domains

Van Strydonck, Niki nvanstrydonck at hayes-lemmerz.com
Fri Dec 17 10:11:32 GMT 2004

Hello all,
Thought I'd let you know what I've been trying in addition to the mail below to get this thing to work. This morning, I installed a second copy of the samba server, and got it to run simultaneously with the existing one. ss1 serves DOM1 and ss2 serves DOM2. ss2 has a copy of the smb.conf file for ss1, only with the workgroup changed to DOM2. Both servers use the same smbpasswd file. 
Using the same WIN98SE computer, when logged in on domain DOM1, I can access ss1, however, when on the same computer logged in on domain DOM2, I still get invalid password to ss2. 
A bit of information I forgot to mention in my mail. The webserver, which for now has a testpage on it, is accessible on DOM1 through http://ss1/ and it also works on DOM2 through http://ss2/ so the error is not network related.
Niki Van Strydonck


From: Van Strydonck, Niki
Sent: Thu 16-Dec-04 16:34
Subject: [Samba] Using samba on two domains

Hello all,
We've been using samba version 3.0.4 on RH9 with success for quite a while now for shares on our domain (DOM1). Since this machine will have to be available in the near future in another domain (DOM2) as a webserver, and limited fileserver, another network interface has been added for the NIC.

When browsing the shares from a WIN98SE computer in DOM2, we are able to see the computer, but when wanting to list the shares, we're prompted for a password. When entering the correct password, we still get "Invalid password". When doing the same on the same WIN98SE computer in DOM1, it is successful. The computer has DSClient for windows 98 installed.

The error logs for the connection from DOM2 gives the following:
smbd/service.c: make_connection(706)
  make_connection: refusing to connect with no session setup

We've tried the following to remedy the problem, without success:
- in smb.conf, add the parameter interfaces, listing the two valid ip-ranges and subnetmasks.
- set the windows registry key to send plain text passwords
- set DOM2 as an accepted host
- tried both encrypt password = yes and no
- We even tried mapping bad password to log in as guest account

Alas, none of these seem to work.

Has anyone had issues with this before? I'd appreciate some pointers.
Thanks in advance,
Niki Van Strydonck

Here's the smb.conf used

workgroup = DOM1
server string = server9
printcap name = /etc/printcap
load printers = yes
printing = cups
log file = /var/log/samba/%m.log
max log size = 0
pam password change = yes
obey pam restrictions = yes
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
username map = /etc/samba/smbusers
guest ok = yes
encrypt passwords = yes
dns proxy = no
 comment = Home Directories
 browseable = no
 writeable = yes
 valid users = %S
 create mode = 0664
 directory mode = 0775
 comment = All Printers
 path = /var/spool/samba
 browseable = no
 printable = yes
 comment = test
 path = /winshare/test
 writeable = yes

More information about the samba mailing list