[Samba] Re: print$ worked in 3.0.7, broken after upgrading to 3.0.9

Jeff Umbach jeff at theserverpos.com
Thu Dec 16 20:34:15 GMT 2004

Well, my problem has changed.

I rolled back to Samba 3.0.7 and the issue was still there, telling me 
that it was a case of corrupted printer drivers in the print$ share most 
likely.  I tried to recopy them in there manually but that didn't work, 
so I deleted them and reinstalled the drivers using the WinXP Add 
Printer Driver Wizard.

This worked and now all computers can download drivers automatically, 
but to my puzzlement the print$ share is still empty.  I looked in the 
directory that it is connected with, /usr/local/samba/printers, but it 
was empty.

So now the drivers are out there, but where?  I'm going to examine the 
server but does anyone have any ideas or have seen this kind of behavior 

Jeff Umbach wrote:
> Franz Pförtsch wrote:
>> Do you have tried:
>> smbclient //<server>/print$ -U <windowsuser>
>> what is happening?
>> I tried following the solution in that thread and it didn't help.  I can
>>> print to the printers if I install the driver manually, but I cannot 
>>> get it to install the driver automatically from the print$ share 
>>> anymore. The "Access Denied" message refers to the printer status.
> I am printing from WinXP Pro SP2, not Linux.  There are no other Linux 
> systems on this network.  All the other Windows computers that already 
> had their printers installed still work but if I uninstall a printer I 
> cannot reinstall it properly.

More information about the samba mailing list