[Samba] Following Samba 3 by example and getting errors.

DeYoung, Brandon Brandon.DeYoung at am.sony.com
Thu Dec 9 19:30:03 GMT 2004

    Hi All,
    I'm having the exact same problem. Did anyone ever figure this out?
Luis G. Riera wrote:

I'm following chapter 6 from samba-3 by example. I've SuSE 9.1 with
OpenLDAP 2.2.6 and samba 3.0.4.  I get four errors with this example.

When I run the testparm -s > test.confect and din't get get error.  The 1th
one error that I got was when I run the program smbclient -L localhost -U%.
It didn't connect.  However, when I run net getlocalsid do get the SID.

The 2th error was in the smbldap conf.pm script.  I made the following
change to correct a Faillior that I got adding this item to the ldap

In the line $computersou = q(People); in: 

# Where are stored Computers 
# Ex: $computersdn = "ou=Computers,$suffix"; ...
$computersou = q(People); 
$computersdn = "ou=$computersou,$suffix";

I have made the following change $computersou = q(Computers); :

# Where are stored Computers 
# Ex: $computersdn = "ou=Computers,$suffix"; ...
$computersou = q(Computers); 
$computersdn = "ou=$computersou,$suffix";

The 3th error is when run ldapadd -x -D "cn=Manager,dc=example,dc=biz" -w
not24get < /etc/openldap/idmap.LDIF I get the following error:

ldapadd: update failed: ou=Idmap,dc=example,dc=biz
ldap_add: Constraint violation (19)
        additional info: structuralObjectClass: no user modification allowed

The last one of the errors is when I run the pdbedit -Lv chrisr that
doesn't conect.

More information about the samba mailing list