[Samba] Samba PDC not adding machines

Kit Gerrits kit at gerritsacc.nl
Wed Dec 8 11:07:38 GMT 2004


Last time I checked (about 2 weeks ago), I could log machines onto the 
domain using the automated join in 2000 (and smbpasswd -a)

Now, when I try to make a machine join the domain, Windows will show 
success, but I can't log in with a domain account!

On adding the machine, I get:

Dec  8 10:40:31 RedHat01 smbd[16299]: [2004/12/08 10:40:31, 0] 
Dec  8 10:40:31 RedHat01 smbd[16299]:   api_samr_set_userinfo: Unable to 

On logging in I get:
Dec  8 11:04:26 RedHat01 smbd[21553]: [2004/12/08 11:04:26, 0] 
Dec  8 11:04:26 RedHat01 smbd[21553]:   get_md4pw: Workstation 
WS-07-2K$: no account in domain

I have tried disabling secure encryption in Policy Settings, but that 
didn't help (The error in the log goes away, but I still can't log in).

I have also tried manually removign and re-adding the machine, to no avail.

Any ideas?

My smb.conf:
# Global parameters
        workgroup = AA-AUDIT-IT
        server string = Server
        password server = None
        log file = /var/log/samba/%m.log
        max log size = 50
        log level = 0
        socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
        add user script = /usr/sbin/useradd -d /dev/null -g samba -s 
/bin/bash -M %u
        add machine script = /usr/sbin/adduser -n -g workstations -c 
Machine -d /dev/null -s /bin/false %u
        logon script = logon.bat
        logon path = \\%L\Profiles\%U
        logon drive = I:
        domain logons = Yes
        os level = 65
        preferred master = Yes
        local master = Yes
        domain master = Yes
        dns proxy = Yes
        wins support = Yes
        guest ok = No
        create mask= 0777
        force directory mode = 0777
        force create mode = 0777
        printer admin = @administrators

... the rest is shares / printer definition

More information about the samba mailing list