[Samba] Problems compiling samba with ldap in solaris 9

Agustín Quint ana Alfonso agustin at iuma.ulpgc.es
Fri Dec 3 10:17:51 GMT 2004

   Hi All,

I get the following error compiling Samba 3.0.9 on Solaris 9. 

Using FLAGS =  -I/opt/local/kerberos/include -DHAS_LDAP  -Iinclude -
I/opt/software/samba/samba-3.0.9/source/include -I/opt/software/samba/samba-
3.0.9/source/ubiqx -I/opt/software/samba/samba-3.0.9/source/smbwrapper  -I. -
I/opt/local/kerberos/include -D_LARGEFILE_SOURCE -D_REENTRANT -
D_FILE_OFFSET_BITS=64 -I/usr/local/include -I/opt/software/samba/samba-
      LIBS = -lsendfile -lsec -lgen -lresolv -lsocket -lnsl -ldl -liconv
      LDSHFLAGS = -G  -lthread -L/usr/local/lib
      LDFLAGS = -lthread -L/usr/local/lib
Compiling dynconfig.c
In file included from include/includes.h:926,
                 from dynconfig.c:21:
include/proto.h:587: error: parse error before "LDAP_CONST"
make: *** [dynconfig.o] Error 1

   I have installed openldap 2.2.17 and MIT kerberos 1.3.5. I run the 
following configuration command without errors:

 ./configure --prefix=/opt/local/samba --with-libiconv=/usr/local --with-ads --
with-krb5 --with-pam

  I have found the same error several times in the list, but nobody answers 
the problem.


More information about the samba mailing list