[Samba] Re: problems accessing samba server from Pocket PC with Windows Mobil e

Vladimir Atanaskovik v_atanaskovik at hotmail.com
Thu Apr 29 19:10:01 GMT 2004

Hi there,

I am experiencing exactly the same problems like described below.
I do not have a solution right now, but I found a work-around that may
help you.

As soon as I change the security parameter in the smb.conf file
from security=user to security=share, mounting shares to Pocket
PC seems to work. (HP iPAQ 4150 running Windows Mobile 2003)

I am running SAMBA V 3.0.2.a and kernel as provided
by the SuSE Linux 9.1 Pro distribution.

So set security=share ( do not forget to specify which user
can access the share in the "valid user =" section for the particular
share) and restart the SAMBA Server.

In my case this worked.


>>Hi Torsten,
>>Sorry I am able to offer a solution to your problem here.  Instead, myself 
>>has encountered the same problem since switching to samba 3 and is hoping 
>>to hear from you if you have got any progress since then.
>>Thanks alot,
>>Looking forward to hearing from you.
>>Best Regards,

>>Isenhardt, Torsten wrote:
>Hi all,
>when accessing a samba server version 2.2.8a from a Pocket PC with Windows
>Mobile 2003
>you can give a password and tell the Pocket PC to remember it.
>But, if you switch off the device or remove the LAN-card the stored 
>is lost (or send in a different way as Pocket PC 2002).
>  Maybe the procedure of sending the stored password has been changed, 
>because Pocket PC 2002 works fine with samba, and accessing a W2K works 
>also fine with Windows Mobile 2003...
>  So, I tried accessing a samba server version 3.0.0 from a Pocket PC with
>Windows Mobile
>2003, but I always got the error message:
>"Cannot find file '\\' (or one of its components). Check to ensure the path 
>and filename are correct and that all required libraries are available."
>I tried to connect to '\\hostname' or '\\hostname\path' but it is alway
>replaced with '\\'.
>When I tried '//hostname' or '//hostname/path' the same error message
>appears with '//hostname' or '//hostname/path' instead of '\\'.
>With Pocket PC 2002 or W2K a connection to samba server version 3.0.0 is
>without any problems.
>Any ideas how to manage this?
>    Torsten

Tired of spam? Get advanced junk mail protection with MSN 8. 

More information about the samba mailing list