[Samba] Problem with Samba 2.2.8a-107 on SuSE 9.0 and 8.3 filenames

Marc mm00 at gmx.de
Mon Apr 12 13:32:43 GMT 2004


I noticed a bug with samba 2.2.8a on my SuSE 9.0 box. I use the 
UltraEdit text editor to edit my php files in a samba share. By default 
this text editor places .bak files next to the changed file.

What I now noticed was this problem:
I edit a file 1234567.php and it generates a file 1234567.php.bak. I can 
open and edit the 1234567.php normally.
I edit a file 123456789.php with the same result as the 1234567.php.

But: Once I edit a file 12345678.php and the 12345678.php.bak file is 
generated, the text editor no longer can access the 12345678.php. If I 
try to open the 12345678.php any application (i.e. even notepad.exe) 
only opens the 12345678.php.bak file. I tried this with several file 
names. It only happens with filenames that have exactly 8.3 characters.

This seems to me like a genuine bug in handling those files. I attached 
my smb.conf in case it only is a configuration error, but this behaviour 
seems rather strage just to be a configuration error, since it only 
happens with files that have the mentioned specific filename format.

So long,


Quoting, forwarding or paraphasing any of the above contents to third 
parties is prohibited without the express written permission of the 
-------------- next part --------------
# Samba config file created using SWAT
# from (
# Date: 2004/04/12 14:38:57

# Global parameters
	workgroup = MYNET
	server string = Linux Server Homesamba
	interfaces = eth0 ipsec0
	security = DOMAIN
	encrypt passwords = Yes
	map to guest = Bad User
	null passwords = Yes
	password server = server01.mynet.de.
	username map = /etc/samba/user.map
	log level = 1
	syslog = 0
	time server = Yes
	unix extensions = Yes
	printcap name = CUPS
	character set = ISO8859-15
	os level = 2
	wins server =
	remote announce =
	printing = cups
	hide dot files = No
	map archive = No
	mangled names = No

	comment = Home Directories
	valid users = %S
	read only = No
	create mask = 0640
	directory mask = 0750
	browseable = No

	comment = All Printers
	path = /var/tmp
	create mask = 0600
	printable = Yes
	browseable = No

	comment = Printer Drivers
	path = /var/lib/samba/drivers
	write list = @ntadmin root
	force group = ntadmin
	create mask = 0664
	directory mask = 0775

	comment = Linux Files
	path = /srv/www/
	username = root,sysadmin
	invalid users = admin
	valid users = root,sysadmin
	read only = No
	create mask = 0664

More information about the samba mailing list