[Samba] Accessing samba machine with IP address but not withfqdn/hostnam e

Scott Moseman smoseman at novolink.net
Mon Apr 5 18:55:30 GMT 2004

What version of Kerberos are you running on your box?
Upgrade to 1.3.1 (or higher) and it may work for you.
I think older versions of Kerberos may not be working
with Active Directory servers.  I had the same issue,
and upgrading my Kerberos version solved the problem.

When you map via IP address, it is using NTLM, AFAIK.
When you map via hostname, it is using Kerberos, which
if you have an old version, is not going to work right.

Scott Moseman

-----Original Message-----
From: samba-bounces+smoseman=novolink.net at lists.samba.org
Sent: Monday, April 05, 2004 1:48 PM
To: 'samba at lists.samba.org'
Subject: [Samba] Accessing samba machine with IP address but not
withfqdn/hostnam e

I have a Debian woody running Samba 3.0.2a in ads security mode as
of a Windows 2003 Active Directory, I run winbind+pam, wbinfo e net ads
testjoin, its all working fine. 

>From any workstation, or even from the W2003 domain controller itself,
can´t access the samba server as \\linuxnetbiosname
<file:///\\linuxnetbiosname> , as \\machine_ip_address
<file:///\\machine_ip_address>  works.

I also could see a error in the log.<machine_name> the messages:

[2004/04/04 00:20:26, 1] smbd/sesssetup.c:reply_spnego_kerberos(173)

  Failed to verify incoming ticket!

After what the user is prompted with a logon screen, even if I type the
correct user and password, he it´s not able to browser in this server.

Any help ?

More information about the samba mailing list