[Samba] Samba 3.0b3+CUPS+server drivers

Boogerman boogerman at interar.com.ar
Thu Sep 11 16:39:37 GMT 2003

I'm trying to setup a printer using Cups, using cupsaddsmb

It uploads the files ok (smbclient ... -c 'mkdir W32X86;put ...;put ...')

It adds the driver ok (rpcclient -c 'adddriver "Windows NT X86"
(I have verified this worked from server properties in "printers and faxes"
of the linux server: the driver "canon" shows up in the list"

Then when it does rpcclient -c 'setdriver Canon Canon' I get:
SetPrinter call failed!

At the same time I run this command, I get this in log.smbd:
[2003/09/11 13:35:38, 0] smbd/oplock_linux.c:linux_init_kernel_oplocks(289)
  Failed to setup RT_SIGNAL_LEASE handler

I'm adding the CUPS postscript with the foomatic ppd of a Canon BJC-1000,
wich is properly configured in CUPS (the print test page works).

Any clues?

Here's my smb.conf:

        netbios name = Natsumi
        server string = Linux Server
        workgroup = BoogerSoft
        passdb backend = smbpasswd

        hosts allow = 192.168.0.

        ;act as domain and master browser
        os level = 64
        preferred master = yes
        domain master = yes
        local master = yes

        security = user

        encrypt passwords = yes

        domain logons = yes

        ;do not set this to \\%N\%U\{whatever}
        logon path = \\%N\profile\%u
        logon drive = H:

        ;logon script, relative to the [netlogon] share
        logon script = logon.cmd

        ;neither of these seem to work with 3.0
        ;client code page = 850
        ;character set = ISO8859-1

        load printers = yes
        printing = cups
        printcap = cups

        comment = Network Logon Service
        path = /home/netlogon
        read only = yes
        write list = ntadmin

        comment = Home Directories
        browseable = no
        writable = yes
        create mask = 0600

        directory mask = 0700

        path = /home/profile
        read only = no
        create mask = 0600
        directory mask = 0700

        comment = Printer Driver Download Area
        path = /usr/local/samba/drivers
        browseable = yes
        guest ok = yes
        read only = yes
        write list = root

        comment = Printers
        path = /var/spool/samba
        browseable = no
        guest ok = yes
        writable = no
        printable = yes
        use client driver = yes

More information about the samba mailing list