[Samba] net view can see server, but nmblookup '*' can't find it!

David Wuertele dave-gnus at bfnet.com
Wed Sep 10 22:07:01 GMT 2003

I have an XP Pro box on my LAN, and I'm trying to figure out why
nmblookup '*' can't see it.  I'm writing a script that finds all the
shares on the LAN and mounts them, and it works great except for this
one box.

On another windows box, when I run "net view", the XP box is listed as
I expect.

On my linux box, when I run "nmblookup -A" it returns
with the correct data about the XP box's shares.

But on the linux box, when I run "nmblokup '*'", it returns all the
other boxes, linux and windows, except for this one XP box.

Here is the output from "nmblookup -d 10 -A".  Can you see
anything that might prevent this box from showing up in "nmblookup '*'"?

Initialising global parameters
params.c:pm_process() - Processing configuration file "/etc/samba/smb.conf"
Processing section "[global]"
doing parameter workgroup = BFNX
doing parameter hosts allow = 192.168.0. 10.2. 127.
doing parameter log file = /var/log/samba/%m.log
doing parameter max log size = 0
doing parameter security = share
doing parameter socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
doing parameter socket address =
doing parameter local master = no
doing parameter username map = /etc/samba/smbusers
doing parameter dns proxy = no
doing parameter encrypt passwords = yes
doing parameter null passwords = yes
doing parameter domain master = no
doing parameter local master = no
doing parameter preferred master = no
doing parameter server string = rave
doing parameter netbios name = rave
handle_netbios_name: set global_myname to: RAVE
doing parameter interfaces =
pm_process() returned Yes
lp_servicenumber: couldn't find homes
set_server_role: ROLE_STANDALONE
added interface ip= bcast= nmask=
added interface ip= bcast= nmask=
added interface ip= bcast= nmask=
added interface ip= bcast= nmask=
bind succeeded on port 0
socket option SO_KEEPALIVE = 0
socket option SO_REUSEADDR = 1
socket option SO_BROADCAST = 1
Could not test socket option TCP_NODELAY.
socket option IPTOS_LOWDELAY = 0
socket option IPTOS_THROUGHPUT = 0
socket option SO_SNDBUF = 65535
socket option SO_RCVBUF = 65535
socket option SO_SNDLOWAT = 1
socket option SO_RCVLOWAT = 1
socket option SO_SNDTIMEO = 0
socket option SO_RCVTIMEO = 0
Socket opened.
Looking up status of
Sending a packet of len 50 to ( on port 137
read_udp_socket: lastip lastport 137 read: 193
parse_nmb: packet id = 32431
Received a packet of len 193 from ( port 137
nmb packet from header: id=32431 opcode=Query(0) response=Yes
    header: flags: bcast=No rec_avail=No rec_des=No trunc=No auth=Yes
    header: rcode=0 qdcount=0 ancount=1 nscount=0 arcount=0
    answers: nmb_name=*<00> rr_type=33 rr_class=1 ttl=0
    answers   0 char .SPACEINVADERS     hex 045350414345494E5641444552532020
    answers  10 char .D.SPACEINVADERS   hex 0044005350414345494E564144455253
    answers  20 char    D.BFNX          hex 2020204400524F4B5520202020202020
    answers  30 char     ...BFNX        hex 2020202000C400524F4B552020202020
    answers  40 char       ......[R..   hex 2020202020201EC400000BDB5B521F00
    answers  50 char ................   hex 00000000000000000000000000000000
    answers  60 char ................   hex 00000000000000000000000000000000
    answers  70 char .......   hex 00000000000000
	SPACEINVADERS   <00> -         M <ACTIVE> 
	SPACEINVADERS   <20> -         M <ACTIVE> 
	BFNX            <00> - <GROUP> M <ACTIVE> 
	BFNX            <1e> - <GROUP> M <ACTIVE> 

More information about the samba mailing list