[Samba] roaming profiles

Andre de Koning andre at vippayroll.co.za
Wed Sep 10 07:18:05 GMT 2003

Hi all.

I'm runnig samba as a DC with win2k clients using roaming profiles.

Since installation I have been experiencing problems with users unable to
log in due to their profiles not loading - some users are on w2k prof end
some use w2k terminal services.

It maily complains about not being able to load (or copy) files like
"prf23.tmp" - access denied etc.

Most of the time if I delete the file in question in eg.
"profiledir/Nethood", "profiledir/Application Data/Microsoft/Office/Recent"
en when I log on again it works.

It now started the profile cannot be loaded bacause some file cannot be
copied and when I go delete the file in the profile dir in the samba box and
try again as usual it still tells me that the profile "cannot be loaded -
logging you in with a temporary profile" - when I click OK a box just pops
up saying "profile cannot be loaded - access denied".

This seems to be entirely random - different client machines and terminal
servers and different user accounts every time.  Sometimes I have to restart
the w2k terminal server for the problem to go away and sometimes I have to
restart smb on the linux box.  This always only fixes some of the users'
logins but others can't log in again - it also only lasts for about 3 hours
that were back when we started.

Sometimes I have to completely delete a user's profile and log into w2k for
it to be recreated before it works again.

I also noticed than if I try to delete the temporary copy of the user's
profile in "Documents and Settings" just after I got the problem I get
"Access Denied" or "Cannot delete, directory not empty" messages from
windows.  When this happens, changing the permissions or ever changing the
files' ownership to Administrator does not help - I have to restart the
machine completely.

I was originally runnig samba 2.2.1a and tried upgrading to 2.2.3, 2.2.5 and
this morning to 2.2.8a.  I also upgraded from redhat 6 to 7 to 7.1 and last
week to 8.0 but this does not make any difference.  I've tried service pack
2 and 3 on the w2k boxes but to 4 - some of my software does not work when 4
is loaded.

Any ideas?

André de Koning
IT Manager
Softline VIP Payroll
Tel: +27 12 420 7000
andre at vippayroll.co.za

More information about the samba mailing list