[Samba] Problems with samba and fam

Andreas Lundin andreas.lundin.2435 at student.uu.se
Tue Sep 2 15:09:35 GMT 2003


I'm having some odd problems with samba in combination with fam. On my linux 
system I have mounted some partitions that are shared by a Win2k machine on 
my LAN. With any GUI filemanager using fam I can create files and 
directories, but I can't delete directories, only files. If I try to delete a 
directory, it just doesn't work. If I try to delete a directory containing 
files, the files will be deleted  but not the directory. I've tried different 
GUI filemanagers and the only one that returns an informative error message 
is nautilus which tells me the directory is "busy", so I guess fam somehow 
thinks the directory is used 
by some other process.

If I turn of fam, or use the console, I can delete the directories without 
problems. The problem occurs only on samba shares, this problem doesn't 
appear in my regular linux file system or on the local windows partitions I 
have mounted. So it seems to be a problem related to fam working together with 
samba (or maybe rather smbmount).

I have tried fam 2.6.7, 2.6.9 and 2.6.10 with samba 2.2.8a on two different 
machine and all with the same error.

I mount the shares with the following line in /etc/fstab

//moya/180gxp1$     /mnt/180gxp1        smbfs 

Is this a known problem, or am I making some glaring error?



More information about the samba mailing list