[Samba] ldap.h: present but cannot be compiled?? Samba 3.0/.1pre1

samba-list at linuxresumes.com samba-list at linuxresumes.com
Thu Oct 16 17:03:11 GMT 2003

Hi all. I am despirately trying to compile samba 3.0 and I get the
following error...I have also tried 3.0.1pre1 as well. I have tried
sunfreeware.com for ldap, my own package I made, and also the latest ldap
from openldap.org... and all produce the following when I try to compile

Any ideas?

checking for LDAP support... auto
checking ldap.h usability... no
checking ldap.h presence... yes
configure: WARNING: ldap.h: present but cannot be compiled
configure: WARNING: ldap.h: check for missing prerequisite headers?
configure: WARNING: ldap.h: proceeding with the preprocessor's result
checking for ldap.h... yes
checking lber.h usability... yes
checking lber.h presence... yes
checking for lber.h... yes
checking for ber_scanf in -llber... no
checking for ldap_init in -lldap... yes
checking for ldap_domain2hostlist... no
checking for ldap_set_rebind_proc... yes
checking whether ldap_set_rebind_proc takes 3 arguments... 3
checking for ldap_initialize... no
configure: WARNING: libldap is needed for LDAP support
checking for Active Directory and krb5 support... yes
configure: error: Active Directory Support requires LDAP support

More information about the samba mailing list