[Samba] Samba 3.0 stable: make --with-afs fails on SuSE 8.2

Joe Samba samba at gnosys.biz
Sat Oct 11 01:29:07 GMT 2003

Hi All-

I have SuSE 8.2 installed on two different Intel machines, with (as far as 
I can determine) all required packages for doing what I'm trying to do 
here.  Both machines suffer the same problems.

I didn't find any SuSE 8.2 rpms, so I'm trying to build Samba 3.0 (stable) 
(24th Sep, 2003) on either of these machines but am having problems with 

As root, I did a "./configure --with-afs" (several other options too---see 
below) and it finished without complaints.  If someone thinks it would 
help, just say so and I'll post it (or a portion of it) in a follow-up.

Actual configure command:
./configure --prefix=/usr --with-fhs --sysconfdir=/etc/samba 
--localstatedir=/var --infodir=/usr/share/info --mandir=/usr/share/man 
--enable-cups --with-privatedir=/etc/samba --with-lockdir=/var/lock 
--with-piddir=/var/run/samba --with-swatdir=/usr/share/samba/swat 
--with-configdir=/etc/samba --with-logfilebase=/var/log/samba 
--with-smbwrapper --with-afs --with-dce-dfs  --with-ldap  --with-ads  
--with-automount --with-smbmount --with-pam  --with-pam_smbpass   
--with-ldapsam  --with-quotas  --with-acl-support  --with-winbind 
--with-krb5=/usr/local --with-mysql-prefix=/usr 

I did a "make" and quite alot compiles ok, but when I get to 
source/auth/pass_check.c, it fails with the messages below:

athena:/home/adam/smb/samba-3.0.0/source # make
Using FLAGS =  -g -O2 -I/usr/local/include  -Iinclude 
-I/home/adam/smb/samba-3.0.0/source/smbwrapper  -I. -D_LARGEFILE64_SOURCE 
-D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE -I/usr/local/include 
      LIBS = -lcrypt -lresolv -lnsl -ldl
      LDSHFLAGS = -shared
      LDFLAGS =
Compiling auth/pass_check.c
auth/pass_check.c:38:22: afs/stds.h: No such file or directory
auth/pass_check.c:39:25: afs/kautils.h: No such file or directory
auth/pass_check.c: In function `afs_auth':
auth/pass_check.c:53: error: `KA_USERAUTH_VERSION' undeclared (first use 
in this function)
auth/pass_check.c:53: error: (Each undeclared identifier is reported only 
auth/pass_check.c:53: error: for each function it appears in.)
auth/pass_check.c:53: error: `KA_USERAUTH_DOSETPAG' undeclared (first use 
in this function)
make: *** [auth/pass_check.o] Error 1
athena:/home/adam/smb/samba-3.0.0/source #

A portion of my source/auth/pass_check.c with line numbers:
      31 #if !defined(WITH_PAM)
      32 static fstring this_salt;
      33 static fstring this_crypted;
      34 #endif
      36 #ifdef WITH_AFS
      38 #include <afs/stds.h>
      39 #include <afs/kautils.h>

I did a "locate stds.h" and "locate kautils.h", and both files are on my 
system, albeit in what seems like an odd place (which may explain the 
failure, but how to correct...)

athena:/home/adam/smb/samba-3.0.0/source # locate stds.h
/usr/include/afs/afs/stds.h      <----------<<<
athena:/home/adam/smb/samba-3.0.0/source # locate kautils.h
/usr/include/afs/afs/kautils.h   <----------<<<
athena:/home/adam/smb/samba-3.0.0/source #

I tried my usual workaround(s) of putting symbolic links to the required 
files in places where the compiler seems to be expecting them (first, I 
linked from /usr/include/afs/afs/stds.h to /usr/include/afs/stds.h and 
that solved this problem, but left others) (then, I made symbolic links 
in /usr/include/afs pointing to all the files in /usr/include/afs/afs), 
but that either fails to help (I still get the same sorts of 
problems---perhaps with other files) or it causes conflicts with other 
#include's and #define's in other .h files elsewhere.  The .h files in 
/usr/include/afs/rx play a role here too.

athena:/home/adam/smb/samba-3.0.0/source # ls -l /usr/include/afs/
total 100
drwxr-xr-x    4 root     root         4096 Oct 10 17:55 .
drwxr-xr-x  106 root     root         8192 Oct 10 18:50 ..
drwxr-xr-x    2 root     root         4096 Oct 10 17:55 afs
-rw-r--r--    1 root     root         1492 Nov  3  2000 des.h
-rw-r--r--    1 root     root         1740 Jun 12  2001 des_conf.h
-rw-r--r--    1 root     root         1421 Mar 13  2003 des_odd.h
-rw-r--r--    1 root     root         7658 Jul  5  2001 lock.h
-rw-r--r--    1 root     root        12507 Aug 26  2002 lwp.h
-rw-r--r--    1 root     root           27 Nov  3  2000 mit-cpyright.h
-rw-r--r--    1 root     root         4710 Nov  4  2000 potpourri.h
-rw-r--r--    1 root     root          970 Jul  5  2001 preempt.h
drwxr-xr-x    2 root     root         4096 Oct 10 17:55 rx
-rw-r--r--    1 root     root         1645 Jul  5  2001 timer.h
-rw-r--r--    1 root     root        14090 Mar 13  2003 ubik.h
-rw-r--r--    1 root     root         5962 Mar 13  2003 ubik_int.h
athena:/home/adam/smb/samba-3.0.0/source #

athena:/home/adam/smb/samba-3.0.0/source # ls -F /usr/include/afs/afs/
./                 budb.h          gtxlightobj.h  prserver.h
../                budb_client.h   gtxobjdict.h   ptclient.h
acl.h              budb_errs.h     gtxobjects.h   pterror.h
afs.h              bumon.h         gtxtextcb.h    pthread_glock.h
afs_Admin.h        butc.h          gtxtextobj.h   pthread_nosigs.h
afs_args.h         butm.h          gtxwindows.h   ptint.h
afs_atomlist.h     butx.h          icl.h          ptserver.h
afs_bosAdmin.h     cellconfig.h    ihandle.h      remote.h
afs_cfgAdmin.h     cmd.h           kaport.h       rxgen_consts.h
afs_clientAdmin.h  cnvldb.h        kauth.h        stds.h
afs_kasAdmin.h     com_err.h       kautils.h      tcdata.h
afs_lhash.h        debug.h         keys.h         usd.h
afs_ptsAdmin.h     dir.h           ktime.h        venus.h
afs_stats.h        dirpath.h       mit-sipb-cr.h  vice.h
afs_sysnames.h     error_table.h   namei_ops.h    viceinode.h
afs_utilAdmin.h    errors.h        netutils.h     vl_opcodes.h
afs_vosAdmin.h     exporter.h      nfs.h          vldbint.h
afscbint.h         fileutil.h      nfsclient.h    vlserver.h
afsint.h           fs_stats.h      osi_inode.h    vnode.h
afssyscalls.h      fsprobe.h       packages.h     voldefs.h
afsutil.h          fssync.h        param.h        volint.h
assert.h           gtxX11win.h     partition.h    volser.h
audit.h            gtxcurseswin.h  prclient.h     volume.h
auth.h             gtxdumbwin.h    prerror.h      xstat_cm.h
bnode.h            gtxframe.h      print.h        xstat_fs.h
bosint.h           gtxinput.h      procmgmt.h
bubasics.h         gtxkeymap.h     prs_fs.h
athena:/home/adam/smb/samba-3.0.0/source #

athena:/home/adam/smb/samba-3.0.0/source # ls -l /usr/include/afs/rx/
total 172
drwxr-xr-x    2 root     root         4096 Oct 10 17:55 .
drwxr-xr-x    4 root     root         4096 Oct 10 17:55 ..
-rw-r--r--    1 root     root        50696 Aug 21  2002 rx.h
-rw-r--r--    1 root     root         7191 Jun 12  2001 rx_clock.h
-rw-r--r--    1 root     root         4081 Nov  4  2000 rx_event.h
-rw-r--r--    1 root     root        15343 Dec 13  2000 rx_globals.h
-rw-r--r--    1 root     root          912 Nov  4  2000 rx_lwp.h
-rw-r--r--    1 root     root         1184 Oct 13  2001 rx_misc.h
-rw-r--r--    1 root     root         1675 Nov  4  2000 rx_multi.h
-rw-r--r--    1 root     root          683 Nov  4  2000 rx_null.h
-rw-r--r--    1 root     root        15871 Sep 19  2001 rx_packet.h
-rw-r--r--    1 root     root         3244 Aug 21  2002 rx_pthread.h
-rw-r--r--    1 root     root         8897 Nov  4  2000 rx_queue.h
-rw-r--r--    1 root     root         2182 Aug 21  2002 rx_user.h
-rw-r--r--    1 root     root         6427 Mar 13  2003 rxkad.h
-rw-r--r--    1 root     root         2774 Mar 13  2003 rxstat.h
-rw-r--r--    1 root     root        12515 Nov 14  2002 xdr.h
athena:/home/adam/smb/samba-3.0.0/source #

If I remove the "--with-afs" option in the ./configure command, and then 
try to make again, then the make finishes with no complaints, so that 
should help explain something.

I could possibly use samba 3.0 without afs support, but I'd really like to 
have it as I expect to be using afs very soon, so I'd like to build in 
whatever support for it samba has.

Can anyone offer some suggestions for solving this problem?  My guess is 
that the SuSE 8.2 distribution puts the .h files from the openafs-devel 
rpm into locations where compilers cannot find them (though perhaps 
there's more to it than that or it's something else entirely), but if 
that is the problem, then what's the best way to fix it?

Many thanks for advice, but regardless of any assistance that may or may 
not be forthcoming, please let me say this:

The SAMBA Team is the GREATEST!!!!

You guys have done such a great service for the IT community by making 
samba, and I am extremely grateful to you!

Best regards,

More information about the samba mailing list