[Samba] Ldap.h missing in samba-3.0.0

Kenny Mann Kennymann at cdrobot.com
Fri Oct 10 14:16:54 GMT 2003

Indeed you are correct, I found this out a couple hours after I sent the
email, I run into another problem with PAM later on, but that's on a
different mailing list.
I can't wait until a distro incorporates Samba 3.0.0 and makes it easily
attachable to a domain and able to talk to a active directory 2K Server
out of the box...
If it ain't out soon, I'm gonna write it myself...

Have a wonderful day and thank you for your response!

Kenny Mann

>-----Original Message-----
>From: Gavin Davenport [mailto:gavdav at gavdav.demon.co.uk] 
>Sent: Friday, October 10, 2003 2:35 AM
>To: Kenny Mann; samba at lists.samba.org
>Subject: RE: [Samba] Ldap.h missing in samba-3.0.0
>configure: error: ldap.h is needed for LDAP support
>You need the openldap-devel package for ldap.h I think.
>-----Original Message-----
>From: samba-bounces+gavdav=gavdav.demon.co.uk at lists.samba.org
>[mailto:samba-bounces+gavdav=gavdav.demon.co.uk at lists.samba.org]On
>Behalf Of Kenny Mann
>Sent: 08 October 2003 19:45
>To: samba at lists.samba.org
>Subject: [Samba] Ldap.h missing in samba-3.0.0
>I have downloaded samba-3.0.0.tar.bz2 (and 
>samba-latest.tar.gz) and attempted to run "./configure 
>--with-ldapsam --with-winbind --with-pam_smbpass 
>--with-smbmount --with-ads --with-ldap" Only to find that 
>./configure complains of a missing ldap.h file. Does anyone 
>else have this issue? I'm trying to do a simple setup to 
>having a Linux box communicate to my Windows 2000 Server PDC, 
>which runs Active Directory. Am I doing something stupid here? 
>I've also tried getting samba-3.0.0 from the salckware.org 
>packages (I run slackware 9.1) and using their package tool to 
>install it via that method, however I have failed getting this 
>to work. After I failed using the Samba documentation, I 
>googled around and found this site: 
>It's been very useful.
>Here is the last snippets of the './configure --with-ldapsam 
>--with-winbind --with-pam_smbpass --with-smbmount --with-ads
>checking for root... yes
>checking for iface AIX... no
>checking for iface ifconf... got 2 interfaces:
>eth0       IP= NETMASK=
>lo         IP= NETMASK=
>checking for setresuid... OK
>checking for working mmap... yes
>checking for ftruncate needs root... no
>checking for fcntl locking... yes
>checking for broken (glibc2.1/x86) 64 bit fcntl locking... no 
>checking for 64 bit fcntl locking... yes checking for 
>st_blocks in struct stat... yes checking for st_blksize in 
>struct stat... yes checking for broken RedHat 7.2 system 
>header files... no checking for broken nisplus include 
>files... yes checking whether to use smbwrapper... no checking 
>whether to use AFS clear-text auth... no checking whether to 
>use AFS fake-kaserver... no checking whether to use DFS 
>clear-text auth... no checking for LDAP support... yes 
>checking ldap.h usability... no checking ldap.h presence... no 
>checking for ldap.h... no checking lber.h usability... no 
>checking lber.h presence... no checking for lber.h... no
>configure: error: ldap.h is needed for LDAP support
>After taking out the --with-ldap and attmepting to re-run configure, I
>checking for LDAP support... auto
>checking ldap.h usability... no
>checking ldap.h presence... no
>checking for ldap.h... no
>checking lber.h usability... no
>checking lber.h presence... no
>checking for lber.h... no
>configure: WARNING: ldap.h is needed for LDAP support
>checking for Active Directory and krb5 support... yes
>configure: error: Active Directory Support requires LDAP support
>Any ideas or suggestions would be extremely appreciated.
>--Kenny Mann
>To unsubscribe from this list go to the following URL and read the
>instructions:  http://lists.samba.org/mailman/listinfo/samba

More information about the samba mailing list