[Samba] Re: can't join to 3.0.1-pre domain

Dmitry Melekhov dm at belkam.com
Fri Oct 10 11:29:58 GMT 2003

Janis Pinkis wrote:

>>>>> I can't add w2k sp3 server to 3.0.1 (cvs from Oct. 6).
>>>>> I trying to add server with root account and w2k says - "Can't find 
>>>>> user name' (trabslation from russian).
>>>> btw, I just tried to the same from w2k server sp4 and winxp 
>>>> workstation and got the same error.
>>>> The same problem is with today CVS ( I tried on two different Linux 
>>>> servers - with Suse 8.1 and RH 7.3).
>>>> And there is no problems with samba 2.2.8a.
>>>> Any ideas?
>>> Hi!
>>> That means You dont have a workstations user account in Your local 
>>> (files or nss) user table. You have to make it by hand or use create 
>>> machine account script in smb.conf.
>> Script is created. I tried the same smb.conf on the same machine with 
>> 2.2.8a and it works!
>> Moreover, I manually created machine account by hands.
>> The same result! :-(
> I'm using 3.0.1 stable on RH9.0 with ldap as nss and passdb backend. I 
> had similar problem, when i was trying to store workstations Unix 
> account information in ldap, when i switched to local passwd file for 
> workstation accounts it started to work. By the way, do you have a 
> account with  uidNumber=0 and sambaSID=xxx-xxx-xxx-1000? Try to look at 
> http://www.unav.es/cti/ldap-smb/smb-ldap-3-howto.html if You are using 
> ldap.

Hmm. 3.0.1 is not available yet, afaik.
And I use smbpasswd backend...
Certanly, I plan migration to ldap, but not now.
First, I need working 2.2.8 replacement :-)

Thank you!

More information about the samba mailing list