[Samba] Re: File deletion problem with samba 2.2.8a and 3.0.0

Laurent Pinchart laurent.pinchart at capflow.com
Fri Oct 10 08:28:08 GMT 2003

> I see the same error message when I try to delete an opened folder in the
> windows explorer in 2.2.8a on FreeBSD 4.8.
> Somebody told me it's fixed in 3.0, but I haven't tried it out yet.

There are two separate problems here. The first one, which has been reported a 
few times, it that deleting a folder from the LEFT pane of windows explorer 
returns an error, because the folder is still open on the right pane, and 
samba 2.2.8 messed up with delete-on-close. That might be what you 
experience, and it's fixed in 3.0.0.

What I experience is a bit different. Trying to delete ANY file or folder 
returns an error. I haven't seen it reported before on this list.

I had a look at a network trace, and found out that windows explorer sends an 
SMBtrans2 message right after the SMBunlink message. The samba server 
responds with a NT_STATUS_OBJECT_NAME_NOT_FOUND error to SMBtrans2, as the 
file has just been deleted. This might be what causes the error message. I 
have no idea why that message is issued and if it is a normal behaviour.

Laurent Pinchart

More information about the samba mailing list