[Samba] RE: Rehat Samba 3.0.0 and MIT KRb 1.3.1 build problems.

Gavin Davenport gavdav at gavdav.demon.co.uk
Thu Oct 9 15:01:50 GMT 2003

I've just tried installing the prebuilt binary rh8_i386 RPM from:
on my redhat 8.0 machine.

It suffers the same (SMB signing) problem as one built from the SRPM:-
running winbindd -i -vv

got principal=pdc$@MYNETWORK.ISP.CO.UK
Doing kerberos session setup
signing_good: SMB signature check failed on seq 1!
SMB Signature verification failed on incoming packet!
scanning trusted domain list

Samba 3.0.0 worked first time on the freebsd machine with heimdal 0.6.

I can't for the life of me get redhat to work.

Gavin Davenport

-----Original Message-----
From: Gavin Davenport [mailto:gavdav at gavdav.demon.co.uk]
Sent: 09 October 2003 15:38
To: samba at lists.samba.org
Subject: Rehat Samba 3.0.0 and MIT KRb 1.3.1 build problems.

Hi there

Because I can't work out how to get the samba 3 SRPM to honour my preferred
krb5 path, I have had to resort to installing the 1.3.1 libraries from
into the directories used by the redhat RPM files (/usr/kerberos)

This gets some way through the build, but fails when linking
Compiling lib/smbldap.c
Compiling smbd/server.c
Linking bin/smbd
libsmb/clikrb5.o: In function `ads_krb5_mk_req':
libsmb/clikrb5.o(.text+0x2a8): undefined reference to
libads/krb5_setpw.o: In function `ads_krb5_set_password':
libads/krb5_setpw.o(.text+0x130d): undefined reference to
libads/kerberos.o: In function `kerberos_kinit_password':
libads/kerberos.o(.text+0x15f): undefined reference to `krb5_cc_initialize'
libads/kerberos.o(.text+0x17b): undefined reference to `krb5_cc_store_cred'
libads/kerberos.o(.text+0x193): undefined reference to `krb5_cc_close'
libads/kerberos.o(.text+0x1dd): undefined reference to `krb5_cc_close'
libads/kerberos_verify.o: In function `free_keytab':
libads/kerberos_verify.o(.text+0x1d): undefined reference to `krb5_kt_close'
collect2: ld returned 1 exit status
make: *** [bin/smbd] Error 1
error: Bad exit status from /var/tmp/rpm-tmp.95539 (%build)

I'm stuck.
1. I can't successfully install krb 1.3.1 RPMs (lots of changes to the RPM
contents - see other mails)
2. Samba doesn't work properly against a 2003 AD server with the 1.2.x krb
libs present on redhat systems (fix is to use 1.3.1 krb libs)
3. The --with-krb5= entry in the spec file is either ignored in the
configure script, or it prefers the system krb5 libs
4. When I install krb 1.3.1 on top of the system krb 1.2.4, samba wont build
(see above)

Heeeeeelp. Is there a way I can let samba use system krb5 libs, but maybe
compile and install heimdal 0.6 somewhere to be linked ???

Gavin Davenport

-----Original Message-----
From: Gavin Davenport [mailto:gavdav at gavdav.demon.co.uk]
Sent: 09 October 2003 09:44
To: samba at lists.samba.org
Subject: RPM build not honouring contents of SPEC file.

Hi there

(redhat 7.1 OS, Samba 3.0.0, against 2003 ADS server)

I built the MIT kerberos libraries from
./configure --prefix/usr/local/kerberos --exec-prefix=/usr/local/kerberos

I now have these in /usr/local/kerberos.

I set the--with-krb5 in the spec file:

        --with-libsmbclient \
        --with-krb5=/usr/local/kerberos \
        --with-ads \

[root at potato SPECS]# rpmbuild -bb samba3.spec
+ '[' '!' -f configure ']'
+ CFLAGS=-O2 -march=i386 -mcpu=i686
./configure --prefix=/usr --localstatedir=/var --with-configdir=/etc/samba -
-with-privatedir=/etc/samba --with-fhs --with-quotas --with-smbmount --with-
pam --with-pam_smbpass --with-syslog --with-utmp --with-sambabook=/usr/share
/swat/using_samba --with-swatdir=/usr/share/swat --with-libsmbclient --with-
krb5=/usr/local/kerberos --with-ads --with-ldap
!!gets it right here!!<snip>

checking whether LDAP support is used... yes
checking for Active Directory and krb5 support... yes

!!then looks in the wrong place!!

checking for krb5-config... /usr/kerberos/bin/krb5-config
checking for working krb5-config... yes
checking krb5.h usability... yes
checking krb5.h presence... yes
checking for krb5.h... yes
checking gssapi.h usability... no
checking gssapi.h presence... no
checking for gssapi.h... no
checking gssapi/gssapi_generic.h usability... yes
checking gssapi/gssapi_generic.h presence... yes
checking for gssapi/gssapi_generic.h... yes
checking gssapi/gssapi.h usability... yes
checking gssapi/gssapi.h presence... yes
checking for gssapi/gssapi.h... yes
checking com_err.h usability... yes
checking com_err.h presence... yes
checking for com_err.h... yes
checking whether Active Directory and krb5 support is used... yes

Why is it doing this ?? I can go and change the configure script to get it
built - but I thought I'd let someone know.
Am I doing it wrong ??

Gavin Davenport

More information about the samba mailing list