[Samba] excel files not opening read only - samba 3.0

Andre de Koning andre at vippayroll.co.za
Wed Oct 8 21:36:22 GMT 2003

I upgraded to samba 3.0 recently.

I have a lot of shares containing excel workbooks that need to be rea only
for certain people and writable by others.

If I try and open any one that is resctricted to read only, whether by samba
"read list" etc. of using linux ext permissions windows compalins that the
file could not be found, check the spelling of the filaname blah blah ...

No errors are reported in the samba log files.  If I copy file to the
windows box and set permissions to make it user have only read access all is
fine, also if I put it on a windows file server with same permissions it

Samba 2.2.3 worked fine and I copied the share definitions accross and kept
it unchanged.

I tried it using linux filesystem permissions ony and also with ext set to
chmod 777 and the resctricting it to read only using "read list" etc.

When I create blank new excel workbooks in these shares it does the same.  I
tried it on various machines with w2k sp2, 3 and 4 using w2k prof, server
and via terminal services.  I've played around with mangling, default case,
various locking option, character sets, renaming files etc. etc. - all to no

Has anybody seen this before?

Please help if you can, this is becoming pretty serious - there seems to be
something seriously wrong with my samba share permissions.
André de Koning
IT Manager
Softline VIP Payroll
Tel: +27 12 420 7000
andre at vippayroll.co.za

More information about the samba mailing list