[Samba] Samba + Cups + Filter Access

Sheldon Hearn sheldonh at starjuice.net
Wed Oct 8 16:51:27 GMT 2003

On (2003/10/08 11:34), Chris Smith wrote:

> On Wednesday 08 October 2003 11:17, Sheldon Hearn wrote:
> > But alas, printing with IPP is fine. :-)
> From Windows or just 'nix?

Just *UNIX.

> > Note that this still doesn't mean the problem is definitely in Samba
> > (although see the WERR_ACCESS_DENIED error below).  It could be a
> > problem with the cups-samba drivers themselves.  I'm using cups-1.1.18
> > and cups-samba-1.1.18.
> Looks like around line 8593 in your log a printer open fails. Maybe in your 
> case the CUPS permissions aren't allowing Samba to print.

Doubt it.  I have this cups configuration:

<Location />
AuthType None
Order Deny,Allow
Deny From All
Allow From
Allow From

> Additionally you can use Adobe's postscript drivers to print to a CUPS
> PPD setup PS printer (try it both ways again - via Samba and IPP). It
> wont provide CUPS page accounting like the CUPS Windows driver but
> would be a good troubleshooting step.

Yeah, I don't care which drivers I end up using, Adobe or Cups.

Taking your advice, I downloaded and installed the AdobePS drivers
on the Windows client and they work just fine.  I downloaded "Adobe
Universal PostScript Windows Driver Installer 1.0.6 - English" from:


However, I was really hoping to use the automagical driver download to
reduce management overhead.  So I tried to copy the files over to the
Samba+CUPS server, as per the cupsaddsmb(8) manpage:


But the AdobePS drivers I downloaded don't install any file matching
ADOBEPS*.* (Windows glob).  The cupsaddsmb(8) manpage suggests that such
files should exist after the installation.

What's the correct driver to download if I want to slap the files on
my Samba server's \print$ share?  All the documentation just says
http://www.adobe.com/.  I have a feeling that, once I get past this
hurdle, I'll be good to go!


More information about the samba mailing list