[Samba] Samba + Cups + Filter Access

Thiago Lima thiagolima at webforce.com.br
Wed Oct 8 14:00:39 GMT 2003


    I'm trying to use Cups + Samba to make a print server for many
purpouses. The main one is to account how many pages where printed by
whom and centralize all printers in one server.

    If I configure samba and cups in the RAW mode using windows original
drivers of the printers, everything works fine, but this way I can't use
cups accounting. 

    So I reinstaled all my printers in cups using their PPD (using
redhat printconf) , and followed the tutorial in linuxprinting.org
ction-3.0-PrintingChapter-11th-draft.html). But even if I got no errors
in the process I can't print from my windows using the cups postscript

    Let me tell what have I done, and how.

    Software :
    Redhat 9.0
    Cups  1.1.17 (rpm)
    Samba 2.2.8a  (rpm) (recompiled from SRPM to force --with-cups )
    Windows XP Pro SP1 as client

    1) configured my printer in cups using printconf. It is working
fine, I can print any postscript from the box.
    2) configured samba  [printers] and [print$] 
    3) installed cups-samba-1.1.19.tgz (in /usr/share/cups/drivers) 
    4) As my server is running in security = share, so I've changed it
to = root (set a smb password for root) and then :  cupsaddsmb  -H
servername  -U root -v D9001 (cupsaddsmb does not seens to work with
security = share) 
       It worked FINE, I got no errors, the files where uploaded to
/etc/samba/drivers/W32X86/2/, rcpcclient where able to adddriver and
setdriver for the printer.

    5) I've changed back security = share to my smb.conf 

    6) In my windows client I've tried to install the printer. (on XP
\\servername right-click on printer, connect). Got no errors

    7) If I go in
I CAN see the driver for the printer. (and If I look in the folder
C:\WIwNDOWS\System32\spool\DRIVERS\W32X86\2 there're there) 

    BUT even with everything working fine I can't print. If I try to
print anything windows gives me an Error, and if I click in properties
of the printer (in my printer&faxes) it says :  "The "printername"
printer driver is not installed on this computer. Some printer
properties will not be accessible unless you install the printer driver.
Do you want to install the driver now?" 

    I'm trying this for 5 days now, and I can't find anything on the
net. I really can't imagine where the problem is, because I followed
every single step that the manuals says and got no errors. 

    Here are the snips...


ldd /usr/sbin/smbd
        libcups.so.2 => /usr/lib/libcups.so.2 (0x4001c000)
        libssl.so.4 => /lib/libssl.so.4 (0x40036000)
        libcrypto.so.4 => /lib/libcrypto.so.4 (0x4006b000)
        libnsl.so.1 => /lib/libnsl.so.1 (0x4015c000)
        libpam.so.0 => /lib/libpam.so.0 (0x40171000)
        libpopt.so.0 => /usr/lib/libpopt.so.0 (0x40179000)
        libc.so.6 => /lib/libc.so.6 (0x40182000)
        libdl.so.2 => /lib/libdl.so.2 (0x402bb000)
        libresolv.so.2 => /lib/libresolv.so.2 (0x402be000)
        libgssapi_krb5.so.2 => /usr/kerberos/lib/libgssapi_krb5.so.2
        libkrb5.so.3 => /usr/kerberos/lib/libkrb5.so.3 (0x402e3000)
        libk5crypto.so.3 => /usr/kerberos/lib/libk5crypto.so.3
        libcom_err.so.3 => /usr/kerberos/lib/libcom_err.so.3
        libz.so.1 => /usr/lib/libz.so.1 (0x40354000)
        /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)


# Global parameters
        workgroup = ESCRITORIO
        netbios name = PENSO-GW
        server string = Penso Server
        interfaces =
        bind interfaces only = Yes
        security = SHARE
        log level = 0
        log file = /var/log/samba/log.%m
        max log size = 50
        name resolve order = hosts wins lmhosts bcast
        socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
        printcap name = cups
        dns proxy = No
        wins support = Yes
        hosts allow = 192.168.0. 127.
        printing = cups

        comment = All Printers
        path = /var/spool/samba
        printer admin = root
        read only = No
        guest ok = Yes
        printable = Yes
        use client driver = Yes
        browseable = No

        comment = Printer Drivers
        path = /etc/samba/drivers
        write list = root
        guest ok = Yes


<DefaultPrinter D9001>
Info Created by redhat-config-printer 0.6.x
DeviceURI smb://printer:jose@MABER/maber-001/hpdesk990
State Idle
Accepting Yes
JobSheets none none
QuotaPeriod 0
PageLimit 0
KLimit 0
<Printer Deskjet990>
Info SP
Location Sp
DeviceURI smb://printer:jose@MABER/maber-001/hpdesk990
State Idle
Accepting Yes
JobSheets none none
QuotaPeriod 0
PageLimit 0
KLimit 0

cupsd.conf ( just an part of it)

<Location /printers/D9001>
Order Deny,Allow
Deny From All
Allow From
Allow From
AuthType None
<Location />
Order Deny,Allow
Deny From All
Allow From
Allow From
Browsing On
BrowseProtocols cups
BrowseOrder Deny,Allow
BrowseAllow from @LOCAL

Any tips, help will be very appreciated.

More information about the samba mailing list