[Samba] Domain Trust and smbclient error.

Tom Ryan tomryan at camlaw.rutgers.edu
Wed Oct 8 03:59:28 GMT 2003

I am trying to get a W2K server to trust a samba 3.0 server.
I followed the directions in the InterdomainTrusts.html file and receive 
an error that the domain is not found when trying to trust it.

my samba server is configured to use pam to authenticate. I had to add a 
user named "w2kdomain$" on the machine before I could run smbpasswd -a -i 
w2kdomain. Once I did that, it created the user just fine.

If I run smbclient -L sambaserver -U localusername and enter my password, 
it uses pam to authenticate it (i am running log level 5 to verify this).

If I run the same command on another box (different version of 
samba/smbclient), it fails. The log file shows that at the same point of 
authentication, there's some pop_sec_ctx calls and then "unix 
authentication failed for user username".

I'm scratching my head at this point..

my smb.conf is miminal, security = user, encrypt passwords = no

any ideas?


More information about the samba mailing list