[Samba] smbmount issues

Bruce Embrey embrey at hood.edu
Wed Oct 1 17:51:34 GMT 2003

Samba List:

I am running samba-client 2.2.7-5.8.0 and am trying to use the smbmount 
command to mount a windows share to my RH8.0 Linux box. Here is the command 
I have tried using:

smbmount "\\\\server.hood.edu\\share" mntpoint -o username=domain\username 

When I do this, I get a failed error message and it prompts me for the password

session request to server.hood.edu failed (Called name not present)

Using smbmount "\\\\server\\share" mntpoint -o username=domain\username 

I get session setup failed: ERRDOS - ERRnoaccess (Access denied.)
SMB connection failed

My purpose is to be able to script mounting a windows share to copy some 
files to my linux directory so I need to be able to mount and dismount this 
share through my script. So far it is not working by feeding the password 
on the commandline. When it prompts me for a password if I enter it the 
mount is successful.

I have also tried feeding the username and password using 
credentials=pass.txt where I have username=bruce and password=mypass on 
separate lines but I get the same errors. My windows server uses NT4 domain 
authenication for attaching to this share. Has anyone been able to get this 
to work or any ideas on how I can fix this?

Bruce Embrey

Bruce Edward Embrey : Linux Systems Manager
Campus Email Admin : UNIX / Linux Administrator
Hood College : embrey at hood.edu : Phone (301)696-392 

More information about the samba mailing list