[Samba] adding machines to Samba domain

A.Subramani a.subramani at outworx.com
Tue Oct 28 06:32:32 GMT 2003

hi all,
       I am experiencing strange problems while adding machines to a
samba 2.2.8a domain. I get an error saying that "the account you used is
a machine account, please user a domain user account...."
I am using RH 9 and compiled samba 2.2.8a from source with the following
./configure  --with-smbmount \
--with-msdfs --with-syslog --with-utmp 2>&1 | tee config.my.log

(I wanted to use smbwrapper but that gives an error during make,
strangely when I first tried it on RH 9 it worked, but now after
repeated attempts smbwrapper does not compile)
I followed the steps in using samba 2nd edition to modify smb.conf to
make Samba the PDC.

I have the following in my smb.cinf
domain admin group = root mani

    ; the below works on Red Hat Linux - other OSs might need a
different command
 add user script = /usr/sbin/useradd -d /dev/null -g 100 -s /bin/false
-M %u 

Now the above command in the smb.conf file is supposed to create an
entry in /etc/passwd and /etc/shadow. It did work when the first time I
tried in in a RH9 (minimal install) box. Now for some strange reason I
cannot add machines from windows2000/xp boxes using the root account
that I created using smbpasswd.

any pointers as to why this is happening? Why I am unable to add windows
machines to the smbdomain?


More information about the samba mailing list