[Samba] Samba3 & LDAP Can't join domain with Win2k Pro

Nicko nicko at free.fr
Sun Oct 26 19:19:35 GMT 2003


I removed Administrator / root account from my LDAP (still have ou, groups
etc. from idealX populating script)
I removed Administrator account from /etc/passwd.

I tried to add with a pdbedit -a -uAdministrator -U0 -G0 -d99
I get an error message : "Unable to find user..."

I create an Administrator account in my /etc/passwd and tried again with the
pdbedit command, it asked me to type password this time (Woot!!!) but at
this end :

smbldap_open: already connected to the LDAP server
ldapsam_modify_entry: Failed to add user dn= uid=Administrator,ou=Users
with: No such object
ldapsam_add_sam_account: failed to modify/add user with uid = Administrator
(dn = uid=Administrator,ou=Users)
Unable to add user! (does it already exist?)

My LDAP is the same from last message...

Here my smb.conf for ldap :
ldap admin dn = "cn=Manager,dc=ERIOS,dc=FR"
ldap ssl = off
passdb backend = ldapsam:ldap://
ldap delete dn = no
ldap user suffix = ou=Users
ldap group suffix = ou=Groups
ldap machine suffix = ou=Computers
ldap suffix = dc=ERIOS,dc=FR
ldap filter = (&(uid=%u)(objectclass=sambaSamAccount))

Une idée ?
A way to restart with an empty LDAP may be ?

thanks all (et specialement Jean Marc)


More information about the samba mailing list