[Samba] Missing "ISO8859-1.so" on Tru64Unix

Giulio Orsero giulioo at pobox.com
Fri Oct 24 14:33:42 GMT 2003

On Fri, 24 Oct 2003 16:08:45 +0200, Kolly Christian
<christian.kolly at nagra.com> wrote:

>I am testing Samba 3.0.0 on a Tru64Unix v 5.1b. I compile it with gcc et
>I am able to start it and I can see a share.
>Until now, I have only one problem: Logs are full of messages like
>"Error loading module '/usr/local/samba/lib/charset/ISO8859-1.so': dlopen:
>Can't open needed library: /usr/local/samba/lib/charset/ISO8859-1.so"
>In fact, I don't find any file "ISO8859-1*" in installed or source

Samba does not ship charset anymore but for cp850/437.

So, either configure didn't pick up your conv libraries or you don't have
suitable conv libraries. Look at config.log for string "iconv".

In my case, while a Red Hat 7.3 install worked out of the box (new glibc
with conversions routines), for an old Red Hat 6.1 (old glibc) I had to
compile libiconv http://www.gnu.org/software/libiconv/, recompile samba to
make it link against it, and then I solved my problems.

giulioo at pobox.com

More information about the samba mailing list