[Samba] Help with Office / Samba samba-2.2.7a on FreeBSD 4.9-RC

J. Nyhuis cabal at u.washington.edu
Tue Oct 21 00:17:23 GMT 2003


System: FreeBSD 4.9-RC
Samba: 2.2.7a

I have a weird SAMBA problem. On my XP Pro box against our Samba server (been
online and such for long time) from Office XP only when ever I save a document
it gets set as read only. Hence I only get one save for any given document.
This is a new problem and is affecting only office XP. Other accounts other
then mine do not have this problem.

I have tried adding in things like force create mask, force security, etc. No
help at all.

This is a really new problem. The problem is there is I can not nail down
exactly when this started.

Also this problem is ONLY in MS Office (Word, Excel, PowerPoint).

In Excel we get the error message: "The Document was saved succesfully, but
Excel cannot re-open it because of a sharing violation. Please Close Document
and try again." The Read-Only bit is now set on the file.

I have tried creating a new user and that user gets this problem too.

I have, in an attempt to solve this, installed ALL the MS Office patches,
problem persists.

If I login as a different user that was using office 2k first the problem does
not exist.

We have not updated Samba nor office. This problem started strangely after we
added the WINS definition....

Do not know if related. Can not find any references to this problem on the

If someone can point me at some things to try I would be deeply grateful!!


More information about the samba mailing list