[Samba] Samba 2.2.3-Debian Roaming Profile Troubles

Austin Godber godber at uberhip.com
Tue May 27 22:14:40 GMT 2003

         I have been having some trouble getting roaming profiles to 
work on my new samba domain.  Actually, it works for some machines but 
not others. First, the server is debian testing with samba "Version 
2.2.3a-12.3 for Debian" and the smb.conf is this:

    server string = calypso01
    netbios name = calypso01
    workgroup = Calypso
    security = users
    domain logons = yes
    encrypt passwords = yes
    wins support = yes
    preferred master = yes
    local master = yes
    os level = 99
    logon path = \\%N\profiles\%u
    logon drive = H:
    logon home = \\%N\%u
    logon script = logon.bat
    time server = yes
    domain admin group= root @admins
    hosts allow = xxx.xxx.xx.192/ printing = cups
    load printers = yes
    printcap name = cups
    socket options = TCP_NODELAY IPTOS_LOWDELAY SO_RCVBUF=8192
    SO_SNDBUF=8192 utmp = yes
    unix password sync = true
    passwd program = /usr/bin/passwd %u
    passwd chat = *password* %n\n *password* %n\n *successful*

    read only=yes
    writeable = no
    browsable = no
    write list=@admins

     path = /home/profiles
     browseable = yes
     writeable = yes
     create mask = 0600
     directory mask = 0700

    comment = Home Directories
    read only = no
    browseable = no
    guest ok = no
    valid users = %S
    create mode = 0664
    directory mode = 0775

The clients are Win2k SP3 machines.  I have two different installs of
Win2k on two different pardware setups.  Both are SP3.  One of the sets 
of machines doesn't work, the other does.  All on the same subnet.  All
machines have been added to the domain successfuly and the users can log
on AND the logon.bat gets executed in both cases.
         The specific behavior I see is that one set of machines 
propogates profiles like I expect.  The other set will pull a profile 
from the server IF there is no profile for that user on the machine 
already, but it will not push any changes to that profile or pull a 
newer profile from the server again.
         The times are correctly synchronized between the server and the
clients (in my logon.bat I run "net time \\calypso01 /set /yes").
         I have noticed that the case of the machine name in "My
Computer->Properties->Network Identification->Properties->Computer Name"
are different between the two machines (of course the NetBIOS name in 
the Advanced Panel is still the same, all caps).  The working machines 
have lowercase names and the non working have uppercase.  But I don't 
see that it matters in some of the network captures I looked at, it 
seems that anytime the workstation name is sent it is sent in all caps.
         Lastly, another problem that has caused some confusion is that 
the machines were on a previous Win2k Domain.  There were some profiles 
for that domain remaining and this has cause some confusion, but I have 
tested on machines free of preexisting profiles, with a clean profile 
and the problem still persists.

Any help would be greatly appreciated.


PS - Please cc my address in any reply as I have not been able to get 
myself registered on the list (local problems)
PPS - Apologies if this gets cross posted.

More information about the samba mailing list