[Samba] Making winbindd and pam_mount play nice together (2nd try)

Bradley Wendelboe bradley.wendelboe at polarisind.com
Sat May 31 03:21:30 GMT 2003

I tested using a local account -- same.  Next I tried uninstalling the 0.9.1
pam_mount and using pam_mount-0.5.9.  After some creative ln -s for
libcrypto and libssl it seems to work *except* that it only works once per
boot.  Here's what I see:

User logs in, winbind does its thing and then pam_mount.  User is in and the
share is mounted.  Logout and pam_mount removes the mount.  So far so good.
Next login the debug shows all is well, (user logged, share mounted) except
that the console hangs and pmhelper never returns.  The share is mounted at
this point but the login times out.


I don't have a winbind system available to test on, but I maintain
pam_mount packages in Mandrake, and so have a test setup, using accounts
only in LDAP via pam_ldap.

I have no problems, currently using pam_mount 0.5.14. I haven't tried
pam_mount with winbind since it added the ~ token (which I needed), but
it did work ...

Have you tried pam_mount with local accounts to ensure that it's not
winbind that is the problem?

BTW, I have had trouble using pam_mount via a stacked pam file (like
/etc/pam.d/system-auth) before, so my test setup uses it in
/etc/pam.d/login directly.


- --
|--------------Another happy Mandrake Club member--------------|
Buchan Milne                Mechanical Engineer, Network Manager
Cellphone * Work            +27 82 472 2231 * +27 21 8828820x202
Stellenbosch Automotive Engineering         http://www.cae.co.za
GPG Key                   http://ranger.dnsalias.com/bgmilne.asc
1024D/60D204A7 2919 E232 5610 A038 87B1 72D6 AC92 BA50 60D2 04A7
Version: GnuPG v1.2.2 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org


Please click on http://www.cae.co.za/disclaimer.htm to read our
e-mail disclaimer.

More information about the samba mailing list