[Samba] Samba and mapping directories for software

Jason Williams jwilliams at courtesymortgage.com
Fri May 30 00:55:55 GMT 2003

Hello again everyone. :)

Well, i've finally fixed a number of problems that I was having with my 
samba/LDAP PDC. Now, its just a matter of setting up some of our users 
software so they can access the data on the server. I will try and explain 
this issue as best as I can without being to wordy. :)

We use a program called point. Point holds files in multiple directories on 
the network server. For our instance, it is holding data in directories 
below /home/point (/home/point/pntdata, /home/point/leads and so forth).

The way point works is that each client has a local version of the software 
installed on their computer. The software is then setup to point to where 
the data is being held. In this instance, I would setup the software to 
point to the samba PDC and into the /home/point folders. (Which ever ones I 
needed to specifically point to.) This is done with a little tool that the 
program comes with. In a nutshell, it's almost like mapping a network drive 
to a directory on the server for the program.

Now, where it gets interesting and confusing is that it wont actually let 
me save the settings. Meaning, I can load up the utility to set the network 
paths, browse to the directory (/home/point/pntdata) have it all set, but 
when I click on OK, it does not save it. I've checked ownership, 
permissions, my smb.conf, everything I can think of, but it will not let me 
map the network path.

So i've come to a stalemate in how to fix this issue and need everyones 
help here.
I thought i'd throw a few things in here in hopes of getting a fix to this 


   comment = Point Program
   path = /home/point
   read only = no
   writable = yes
   browseable = yes
   create mode = 660
   directory mode = 770
   admin users = @domadm
   force group = +cm


drwxrwx---   51 root     cm           4096 May 29 15:12 point

I have made sure that the test user is in fact in the cm group. (The 
permissions, owner and group are the same down the following directories.)

The only other bit of information I can provide is some info from my logs:

[2003/05/29 17:37:25, 2] smbd/open.c:open_file(243)
   bionic opened file PNTDATA/FOLDER.INI read=Yes write=No (numopen=1)
[2003/05/29 17:37:25, 2] smbd/open.c:open_file(243)
   bionic opened file PNTDATA/FOLDER.SEC read=Yes write=No (numopen=2)
[2003/05/29 17:37:25, 2] smbd/close.c:close_normal_file(227)
   bionic closed file PNTDATA/FOLDER.SEC (numopen=1)
[2003/05/29 17:37:36, 2] smbd/close.c:close_normal_file(227)
   bionic closed file PNTDATA/FOLDER.INI (numopen=0)
[2003/05/29 17:38:42, 2] lib/access.c:check_access(327)
   Allowed connection from  (
[2003/05/29 17:38:46, 2] lib/access.c:check_access(327)
   Allowed connection from  (
[2003/05/29 17:38:51, 2] smbd/open.c:open_file(243)

PNTDATA is located in /home/point/PNTDATA

Not sure if this can help, but thought i'd put it in here.

One quick note: About 1 1/2 months ago, I was doing some testing with our 
new point software on another samba server. This one worked fine and 
allowed me to map the drives with problems at all. I pretty much made the 
owner and group nobody.nobody with 777 permissions. I tried this on my 
current setup but no luck.

I thank you for everyones help and really look forward to finding out what 
the problem is.



More information about the samba mailing list