[Samba] Re: Samba+CUPS+Drivers autodownload

Dragan Krnic dkrnic at lycos.com
Thu May 29 23:35:16 GMT 2003

>> Samba built with this change will not report
>> NT_STATUS_UNSUCCESSFUL when you execute "adddriver"
>> subcommand of rpcclient.
>I found reference to this in one of your posts and in 
>Samba's bugzilla database. I've tried commenting out 
>this code, rebuilding, installing, etc. but I still 
>get the error.

Unfortunately, many conditions can lead to the
same symptoms. Omitting a mandatory field in the
third parameter, mixing files from different levels,
versions and OS's, improper path permissions, etc.

You should increase the logging level drastically,
e.g. "smbcontrol smbd debug 999" execute the command,
reduce the logging level and pore over the logs. 

>> The other bug prevents rpcclient's "enumdrivers"
>> subcommands from completing and can be fixed by 
>This fix is in the CVS version I checked out. Their 
>fix is slightly different, but I can see it does the 
>same thing.

>> Another problem is building a fixed version of 
>> Samba. Somehow, the Linux vendors refrain from 
>I'm running on Slackware, so there's a Slackbuild 
>script in the source tree that explains how Samba was 
>built. At the moment I'm just doing a standard
>./configure build as I just want to see if this 
>printing will work smoothly.
>As of the current CVS checkout I made yesterday, and 
>trying your commenting-out fix, I still get the 

Might it be, that your edits get somehow ignored
by the build script? Dumb question, perhaps.

Get advanced SPAM filtering on Webmail or POP Mail ... Get Lycos Mail!

More information about the samba mailing list