[Samba] Setting up CUPS for Samba on 390

Josh Konkol samba at guidemail.com
Fri May 23 13:41:28 GMT 2003

I've scoured the newsgroups and asked MANY people, does anyone out there 
have any ideas ?

I'm new to the CUPS arena and I'm trying to figure out what to do from 
the separate docs.  I'm using SLES7 (2.4.7 kernel).  The files I'm using 

4368072 May 22 06:22 cups-1.1.19rc5-source.tar.gz
197341 May 22 06:22 cups-samba-1.1.19rc2.tar.gz
4961128 May 22 07:58 ghostscript-7.05.tar.gz
14520320 May 22 06:22 gimp-print-4.3.14.tar
610697 May 23 06:20 pkgconfig-0.15.0.tar.gz
5463358 May 22 06:24 samba-2.2.8a.tar.gz

So far I have compiled cups, ghostscript (with the cups patch), cups-
samba drivers, & samba with cups enabled.

I have setup my smb.conf file to use cups and I can see the printer I 
setup through Network Neigh.  I used the windows interface to install the 
printer driver and I can install the driver onto my client through the 
APW interface.  When I try to print I get "test page failed to print"  
I'm guessing it's because I don't have the gimp-print package installed 
yet, and that's where I'm stuck.

When I ran "./configure --with-cups --without-gimp --disable-gimp-test" 
for the gimp-print package I got errors about not finding glib-config and 
pkg-config.  I found the pkgconfig package at the url listed in the 
error.  I did the usual configure,make,make install, but then it gave 
errors about not finding .h files.  I went through one at a time moving 
them to the /usr/local/include directory because apparently the make 
install doesn't do that.  

Now I still get errors surrounding glib-config and pkg-config.

Am I going down the right path here ?  I've 



More information about the samba mailing list