[Samba] some simple samba problems

Joel Hammer Joel at HammersHome.com
Thu May 15 20:51:46 GMT 2003

Well, I think you will have to go on something besides noise in the printer
to trouble shoot this thing.

I don't know a thing about cups. I gave up on it because it was too
complicated for me. lprng works fine.

The print process in samba is very simple. The windows client sends the
preformatted or filtered job to the spool directory on the samba server (the
path parameter.) Then samba invokes the server printing command. With cups,
the commands are hidden from you, which doesn't make this problem any
easier, it seems.

SO, I would try this.

Make printing = lprng
Make your printing command = echo "the print job is %s" > /tmp/signal

Then try to print the job with the cups command, whatever that is.

When you say you send a test page, this is a problem. A "test page" if
generated by the printer installation program may be sent to a special
queue, not the queue you send your other jobs to.  Yes,  I know, this
is crazy but....
     On my lexmark the test page, a complicated binary file
     just for this printer,  went to a raw queue, whereas the
     real print jobs got sent to a postscript queue. Go figure.


On Thu, May 15, 2003 at 02:52:38PM -0500, christopher j bottaro wrote:
> > There is a path parameter in your share definition. That is where the print
> > job is sent from the client.
> > You could make:
> >      printing command = echo "tried to print %s" > /tmp/signal
> > And see what is in signal.
> >
> > %s will not show the whole path name, just the print job name, since
> > the path name in the share is assumed.
> >
> > Joel
> ok, when i try to print a windows test page, sometimes (not all the time) the 
> printer makes noise, but nothing comes out, and something is made in 
> /var/spool/cups, but not in /var/spool/samba.  if the printer doesn't makes 
> noise and is silent, something is still made in /var/spool/cups, but not 
> /var/spool/samba.
> > If you are using cups, why not tell samba about it?
> > In smb.conf, try
> >
> > printing = cups
> > printcap name = cups
> > load printers = yes
> my "printing" is already set to cups, but i changed "printcap name" like you 
> said, but no good results...=/
> > with problem 1 you might like to try making writeable = yes    and perhaps
> > if you're not concerned about security put public = yes as well....  the
> > other too i've no idea sorry.  only the first one as i've just tried to do
> > it as well..  ;)
> i tried making it writeable, but it didn't do anything...=/
> thanks again for the help,
> -- christopher

More information about the samba mailing list