[Samba] Error opening libncurses.so.4

Jorge Cecílio cecilio at equitubos.pt
Thu May 15 15:39:54 GMT 2003

Hi all,

I'm finishing my first-time install and configure pre-compiled samba 2.2.6 on
OpenServer 5.0.6 and although I've still minor problems (...), everything
seems to be working fine (I've done several tests)...

However, when I run  smbclient,  a error message prints:

dinamic linker: smbclient: error opening /usr/local/lib/libncurses.so.4

Some issues about  libncurses.so.4 on my OpenServer server:
1) /usr/local/lib is empty  (is linked to
2) There is no  libncurses.so.4 on disk;
3) On a Caldera Samba support ("How do I download, compile and Install the
latest version of Samba on OpenServer?") is written:
    "Should you receive error messages regarding  "libncurses.so.4"  ensure
that /usr/local/samba/bin is linked
    to /usr/local/samba/sbin."

    Because(?) I'm running Samba on OpenServer, there is no
/usr/local/samba  directory. May be it is  /usr/lib/samba...
   Should I link /usr/lib/samba/bin  to  /usr/lib/samba/sbin? Using   ln -s
/usr/lib/samba/bin  /usr/lib/samba/sbin   unix command?
   (I've tried that. It seems not to work.)

Can you please help?

More information about the samba mailing list