[Samba] Domain trust problem? (3.0 alpha 23)

Ladner, Eric (Eric.Ladner) Eric.Ladner at chevrontexaco.com
Thu May 15 14:41:22 GMT 2003


I have two computers, both running HP-UX 11.0, both running 3.0 alpha23
(the second computer's samba trees were copied from the first, so they
are identical).

Mapping a drive from an XP SP1 computer has NO problems on the first HP
server.  On the second one, it displays the message "Configuration
information could not be read from the domain controller, either because
the machine is unavailible, or access has been denied."

The smb.conf files are identical (config below).

One thing I did notice and try to connect is that in the secrets.tdb
file on the first computer there was a MACHINE_PASSWORD entry for the
first computer.  The second computer, after firing up samba the first
time added an entry for the other computer but it didn't have a
machine_password.  I'm not sure how the password entry was added to the
first computer since it never was actually added to the domain.  I tried
deleting the secrets.tdb file on the second computer and tried to
recreate it but haven't had any luck.

[/opt/samba/private]$ strings secrets.tdb
TDB file

The second machine only has the "SECRETS/SID/system" entry.

### smb.conf entries -----------------------------------------------
# Global parameters
        workgroup = CT
        server string = WWW Samba Server
        security = DOMAIN
        password server = pasmsntad1.pasms.chevrontexaco.net
        guest account = smbnull
        username map = /etc/opt/samba/users.map
        log level = 2
        log file = /var/opt/samba/log.%m
        max log size = 300
        local master = No
        dns proxy = No
        oplocks = No

        comment = Home Directories
        read only = No
        force create mode = 0664
        force directory mode = 0775
        browseable = No

#  Machine log from the system that doesn't work.
#  This is the log for the client attempt.
[2003/05/15 10:16:55, 0] auth/auth_domain.c:check_ntdomain_security(422)
  check_ntdomain_security: could not fetch trust account password for
domain 'CT'
[2003/05/15 10:16:55, 2] auth/auth.c:check_ntlm_password(275)
  check_ntlm_password:  Authentication for user [CLAD] -> [www] FAILED
[2003/05/15 10:17:05, 2] smbd/server.c:exit_server(577)
  Closing connections

More information about the samba mailing list