[Samba] cli_pipe: return critical error. Error was Call returnedzerobyte(EOF),hilfe!

Dragan Krnic dkrnic at lycos.com
Tue May 13 21:48:51 GMT 2003

>Dragan Krnic wrote:
>> |.................
>> |       This would *possibly* map to the files of >> |       your river like this:
>> |
>> |         Long Printer Name:\            -->  lp:\
>> |...........................
>> |                missing: should be "RAW" !! #####
>> |
>> |    Yeah, you're right. I've missed the RAW DDT. 
>> |    Now when I complied I got the error from the 
>> |    subject line.
>> |
>> | Sorry? I didn't get that: you forgot the "RAW" 
>> | when you quoted the adddriver command in the 
>> | mail, or you forgot it in the command itself?
>> In the command. When I added it, I got other error.
>Which one, which one? You didn't name it.
>($SUBJECT reads still the same...)

The cli_pipe error, as in the eMail's subject line.

>> |    Something else: I tried enumdrivers. Without 
>> |    level parm it shows me level 1, but if I 
>> |    specify level 2 or 3, it prints
>> |     [Windows 4.0]
>> |     Segmentation fault.
>> |
>> |    Perhaps I should scratch those nt*.tdb's and 
>> |    try again?
>> |
>> | This helps sometimes. Delete them (or move them 
>> | away) and start all over.
>> I did. I scratched the files and then repeated the
>> compliant rpcclient with debug level at 999. The 
>Was that "cupsaddsmb" or "rpcclient adddriver" 
>or "rpcclient setdriver"?

Both were.

>If it was "cupsaddsmb", what were the intermediate 
>results for the adddriver command?

cli_pipe error

>What are your settings for smb.conf? (use f.e.

strictly by the book.

>> I have attached
>> a bzip2 compress of the log. Perhaps you can dig out
>> something interesting.
>No time right now, sorry. (This is a 7.000 lines long 
>file. Maybe you should turn off the  >timestamping, "timestamp logs = no". This makes often 
>for easier reading.)

Well, it's easy to strip out. I like it with stamps
because i can catenate between two successive
stamps and then look at it on my extra wide screen
(2480) with xterm set to tiny. The way logs are
normally produced is very confusing to me. I'm lost
in so many lines because they don't rhyme. When you 
lookit as a long line you can grok patterns better.
The info starts to rhyme.

>> It has actually moved all files from W32X86 to 
>> 32X86/3 but if I query enumdrivers it reports 
>> segmentation fault again.
>BTW, I have digged out that bug report about 2.2.8a 
>for you, and the response I received (which forced 
>*me+ to go back to 2.2.7a):
>#>>> this is what I am finding with "rpcclient 
>#>>> enumprinters" and "rpcclient enumdrivers". It 
>#>>> wasn't working in all levels in previous Samba 
>#>>> versions for me either, but 2.2.8a seems to have 
>#>>> it broken worse than it was before. The 
>#>>> consequence: "cupsaddsmb" doesn't succeed any 
>#>>> more with 2.2.8a.
>#>>> Executive Summary:
>#>>> ------------------
>#>>> * "cupsaddsmb" doesn't work, because....
>#>>> * "rpcclient enumprinters" doesn't work in all 
>#>>>   levels -- some give segfaults
>#>>> * "rpcclient enumdrivers" doesn't work in all 
>#>>>   levels -- some give segfaults
>#>>> It would be very useful if this could be fixed 
>#>>> with an upcoming Samba 2.2.9 release.
>#> I'll fix it.  It is a NULL pointer being passed to 
>#> a printf() somewhere.
>You may want to go back to 2.2.7a too -- it is not 
>ruled out that you are hitting the same bug as /me

I may have to go as far back as 2.0.7 to be on the
safe side but I won't. I'll try to fix it here. What
I found out in those profuse logs is that actually 
something happens inside tdb_store function in 
tdb/tdb.c. It might be a NULL ptr but I'm too tired
to lookit up now. I'll add some more detailed
diagnostics in that function and see where it dies.

On the same server I can't build samba becuase
configure aborts after "checking  whether to use
included popt... ./popt". A few tests before that
"checking whether or not getgroups returns EGID too many times..." says "yes", which it doesn't on the
standby server with basically the same hardware and
software. Does it ring any bells?

Thanks a lot Kurt for being such a good pen pal.
We'll fix it one way or another.


Get advanced SPAM filtering on Webmail or POP Mail ... Get Lycos Mail!

More information about the samba mailing list