[Samba] cli_pipe: return critical error. Error was Call returnedzerobyte(EOF),hilfe!

Kurt Pfeifle kpfeifle at danka.de
Tue May 13 21:07:02 GMT 2003

Dragan Krnic wrote:
> |.................
> |       This would *possibly* map to the files of your 
> |       driver like this:
> |
> |         Long Printer Name:\            -->  lp:\
> |...........................
> |                missing: should be "RAW" !! #####
> |
> |    Yeah, you're right. I've missed the RAW DDT. Now
> |    when I complied I got the error from the subject
> |    line.
> |
> | Sorry? I didn't get that: you forgot the "RAW" when 
> | you quoted the adddriver command in the mail, or you 
> | forgot it in the command itself?
> In the command. When I added it, I got other error.

Which one, which one? You didn't name it. ($SUBJECT reads
still the same...)

> |    Something else: I tried enumdrivers. Without level
> |    parm it shows me level 1, but if I specify level 2
> |    or 3, it prints
> |     [Windows 4.0]
> |     Segmentation fault.
> |
> |    Perhaps I should scratch those nt*.tdb's and try
> |    again?
> |
> | This helps sometimes. Delete them (or move them away)
> | and start all over.
> I did. I scratched the files and then repeated the
> compliant rpcclient with debug level at 999. The 


Was that "cupsaddsmb" or "rpcclient adddriver" or "rpcclient

If it was "cupsaddsmb", what were the intermediate results
for the adddriver command?

What are your settings for smb.conf? (use f.e.

     grep -v ^$ /etc/samba/smb.conf/ | grep -v ^# | grep -v "^;"

to filter out comments and empty lines)

> I have attached
> a bzip2 compress of the log. Perhaps you can dig out
> something interesting.

No time right now, sorry. (This is a 7.000 lines long file.
Maybe you should turn off the timestamping, "timestamp logs
= no". This makes often for easier reading.)

> It has actually moved all files
> from W32X86 to 32X86/3 but if I query enumdrivers it
> reports segmentation fault again.

BTW, I have digged out that bug report about 2.2.8a for you,
and the response I received (which forced *me+ to go back to

#>>> this is what I am finding with "rpcclient enumprinters" and "rpcclient
#>>> enumdrivers". It wasn't working in all levels in previous Samba versions for
#>>> me either, but 2.2.8a seems to have it broken worse than it was before. The
#>>> consequence: "cupsaddsmb" doesn't succeed any more with 2.2.8a.
#>>> Executive Summary:
#>>> ------------------
#>>> * "cupsaddsmb" doesn't work, because....
#>>> * "rpcclient enumprinters" doesn't work in all levels -- some give segfaults
#>>> * "rpcclient enumdrivers" doesn't work in all levels -- some give segfaults
#>>> It would be very useful if this could be fixed with an upcoming Samba 2.2.9
#>>> release.
#> I'll fix it.  It is a NULL pointer being passed to a printf() somewhere.

You may want to go back to 2.2.7a too -- it is not ruled out
that you are hitting the same bug as /me

>>From where I now sit I can't use ftp for uploads. All 
> files are 3.5 MB compressed, so I can't mail it either.
> I'm stuck.
> cupsaddsmb has the same problem trying to set up a 2
> printer. The files are there but enumdrivers segments.
> Cheers
> Dragan


More information about the samba mailing list