[Samba] cli_pipe: return critical error. Error was Call returned zero byte (EOF), hilfe!

Kurt Pfeifle kpfeifle at danka.de
Mon May 12 16:18:34 GMT 2003

Dragan Krnic wrote:
> Hi Kurt,
> I tried to explain my problem to you at Göttingen
> but it looks like I'm the only one who gets this
> error.
> I've just reinstalled my box with SuSE 8.2, kernel
> 2.4.20-62, samba 2.2.8a, and cups 1.1.18, moved all 
> config files, databases, scripts and jobs to it and
> it looks like samba has become even better and faster. 
> No one noticed anything wrong except I just can't come
> to terms with cups. I hoped my problem would be gone
> with the new installation but it wouldn't.
> I've gone strictly according to the book, your
> "Printing with CUPS (Samba 2.2.x and 3.0)", which
> I picked up at Samba Experience,

Please get yourself the updated version from


It contains a lot more material on that question,
including how to do it all manually with rpcclient.

> but I still get
> the same buggy result NT_STATUS_UNSUCCESSFUL when
> cupsaddsmb executes adddriver for "Windows NT x86"
> and "Windows 4.0" as well as when it finally does
> the set driver. Here is a slightly edited log:

Sorry, I don't have time right now to look thru that log
in detail. But probably I will tonight, in which case you
will find s.th. in your mailbox tomorrow morning...


More information about the samba mailing list