[Samba] Multiple Printers on LPT

Mikevl Mikevl at paradise.net.nz
Tue May 6 01:15:14 GMT 2003

Hi I have tried many suggestions now as per the list but still no joy. My
system is redhat 7.2. I am trying to access it from WinXP and Win2K


Many thanks


# Printing from the general section

        printcap name = /etc/printcap
        load printers = Yes
        printing = bsd
        load printers = yes
        show add printer wizard = yes
        printcap name = /etc/printcap
        printer admin = @ntadmin, root
        total print jobs = 100
        lpq cache time = 20
#       use client driver = no

        comment = All Printers
        browseable = no
        printable = yes
        public = yes
        create mode = 0700
        guest ok = yes
        read only = yes
        writable = no

        path = /var/spool/lpd/HP1200
        directory mode = 0775
        valid users = @users, Mike, notebook$
        printable = yes
        printer name = HP1200
        create mask = 0775
        directory mask = 0775
        printer admin = @users, Mike, notebook$
        browseable = yes
        printable = yes
        writeable = no
        guest ok = yes
        print command = lpr -P %p -o raw %s -r

----- Original Message -----
From: "Jason Balicki" <kodak at frontierhomemortgage.com>
To: <Linux at dounsix.co.nz>
Sent: Tuesday, May 06, 2003 1:22 AM
Subject: Re: [Samba] Multiple Printers on LPT

> When I install the printer on either the WinXP or Win2k PC then I get
> "access denied" really frustrating.

You'll find that you can probably print to them.  Most likely your
problem is that you have no machine account on the samba
box for the XP and 2k machines.


smbpasswd -a -m <machinename>

for each XP and 2k machine.

In most *nixs' you'll have to do this first though:

useradd -d /dev/null -s /bin/false <machinename\$>

since samba needs a unix account to latch onto.



More information about the samba mailing list