[Samba] Mapping samba shares to a second linux box

Andrew Niven niven at cdxit.com
Tue Mar 25 04:44:12 GMT 2003


I have a very frustrating problem and I can't seem to find a solution.  I am
running redhat 8.0GPL and samba 2.2.8 on two linux boxes.  The first linux
box is my storage (used by multiple pc's).  The second is my web-server
running apache and php.  The web-server recieves files which are meant to be
stored to the first linux box and processed by other computers on the

The following is the smb.conf file.

  encrypt passwords   = yes
  guest account           = smbuser
  hide unreadable        = yes
  hide dot files             = yes
  log level                    = 3
  log file                      = /var/log/samba/%m.log
  netbios name            = myserver
  security                    = user
  server string             = "Development Storage"
  socket options         = TCP_NODELAY IPTOS_LOWDELAY SO_RCVBUF=8192
  time server              = yes
  wins support           = yes
  workgroup              = myworkgroup

  browseable             = yes
  create mode           = 0666
  directory mode       = 0777
  directory mask       = 0775
  guest ok                 = yes
  guest only              = yes
  path                       = /share/webdocuments
  read only               = no

I can connect to the webdocs directory from a windows box, browse read, edit
and create files/directories.

on the second linux box I use automout as follows


/share /etc/auto.share  --timeout=600


webdocs  -fstype=smbfs,username=smbuser,password=smbuser://

The problem is the automount seems to work, the directory is available and I
can browse, view and edit the files.
However I cannot create files in the in the share unless I am logged in as
root.  This means that I cannot recieve files with PHP and push them off to
the storage server.

I have tried different settings all to no avail.  I have tried everything I
can think of and can't get this to work.

Can anybody help me.


More information about the samba mailing list