[Samba] Possible Bug?? (was: Win95 & Win98 - NOT WORKING - NT,2000, XP are ok)

peter.a.bryant at mainroads.qld.gov.au peter.a.bryant at mainroads.qld.gov.au
Wed Mar 19 07:02:56 GMT 2003

Please lend me some expertise...

Ok, I know suggesting a bug is a bit impolite, but I cannot find a solution for
this and
none of the helpful people who have responded have been able to help either...
If I come off sounding a bit short it's just because I've tried many things to
get these
older clients printing.  :-)  Don't mean to annoy anyone.  Appreciate any help!

Have several pressing reasons to upgrade to newest Samba (including latest
security fix)
but cannot do this if it means the Win9x clients can't print.

The important point here is that everyone is printing fine on old Samba server.
Have replicated permissions and conf file is pretty much the same for the new
Samba server.
It isn't a permissions thing because the Win9x clients are successfully sending
the print job
to the spool directory.  Then the print job is getting stuck there.
The job being stuck in the spool directory doesn't stop others from printing
though. (Other NT, 2000, XP clients that is)

Obviously most people are able to print from Win9x .
Just wondering if maybe this is a Solaris + HP printers thing??
Thought maybe it was a printer driver issue, But it is printing okay from the
old Samba
so surely this is not the problem?

Any ideas?  Can anyone replicate my problem?  Is anyone else using Solaris + HP
+ Samba 2.2.7a  ?

thanks & sorry


RE: [Samba] Win95 & Win98 - NOT WORKING - NT,2000, XP are ok (re

 Printing is working fine for our Windows NT, 2000 and XP clients.
 However, with windows 95 & 98, the print job gets put into the Samba
 spool directory (path = /var/spool/lp/tmp/samba)  but doesn't make it
to the printer.
 The print files stay there in the directory - don't get removed.

 Samba version is 2.2.7a,  on Solaris 8
 Printers are HP printers - e.g. HP 8100dn

 All clients including 95/98 were happily printing on a very much older
version of Samba (2.0.6)
 network setup is a peer to peer network.

 printing directly from Unix to the printer is working ok

 (p.s. Just for a wild stab in the dark I tried setting the
"disable spoolss =   yes"
 but this stopped all printing from making it to the computer - even
from the  clients that  were originally working.)

 relevant bits of conf. file included below...
 note that I don't have print command explicitly stated, but testparm
 indicates that it is configured properly...

   printing = sysv

  lprm command = /usr/bin/cancel %p-%j
  lppause command = lp -i %p-%j -H hold
  lpresume command = lp -i %p-%j -H resume
  load printers = no

  printer = hp8100dn_1
 comment = HP LaserJet hp8100 DN
 path = /var/spool/lp/tmp/samba
 guest account = nobody
 guest ok = yes
 browseable = yes
 printable = yes
 writable = yes

Opinions contained in this e-mail do not necessarily reflect
the opinions of the Queensland Department of Main Roads,
Queensland Transport or National Transport Secretariat, or
endorsed organisations utilising the same infrastructure.
If you have received this electronic mail message in error,
please immediately notify the sender and delete the message
from your computer.

More information about the samba mailing list