[Samba] Win95 & Win98 - NOT WORKING - NT,2000, XP are ok (re posted)

peter.a.bryant at mainroads.qld.gov.au peter.a.bryant at mainroads.qld.gov.au
Sun Mar 16 22:31:42 GMT 2003

Our setup is peer to peer, rather than a domain setup.
So security is set to   "server"

Generally though, we are using the same conf. file for this new Samba as
the one we had (have)  in production (on Samba 2.0.6).

So I guess what I need to know is what has changed in regards to printing with
Win95, 98
from 2.0.6 to 2.2.7a  ?



Peter Carpenter <peterc at osm.co.uk> on 14/03/2003 09:45:28 PM

Did you change your "security" setting in your new Samba e.g. from "share"
to "domain"?

-----Original Message-----
From: peter.a.bryant at mainroads.qld.gov.au

I tried adding the [printers] section to my conf file as John suggested, but
this didn't solve the problem.
Still able to print from NT, 2000, XP  and not from Win95, 98

just recapping - am able to print from all clients with the old version
which we are still using in production

With the new Samba (2.2.7a) the file sharing is fine, but printing only
for NT,2000,XP
With Win95 & Win98 only, the file gets put in the spool directory but
seem to get
sent from the spool directory to the printer. (or picked up by the printer -
however it works...)

Any idea if Win95, 98 printing is treated differently to the newer OS's ?

thanks for any thoughts.

see below for other details...


>> >>
>> >>Sorry to have to repost this (didn't get any response on the first
>> >>we really need some of the fixes of the new Samba but cannot go ahead
>> >>the support for the older machines.
>> >>Need to prove that Samba is the great product that I believe it is.
>> >>
>> >>Hi folks - I am having printing problems with our older machines.
>> >>
>> >>Printing is working fine for our Windows NT, 2000 and XP clients.
>> >>However, with windows 95 & 98, the print job gets put into the Samba
>> >>spool directory (path = /var/spool/lp/tmp/samba)  but doesn't make it
>> >>printer.
>> >>The print files stay there in the directory - don't get removed.
>> >>
>> >>Samba version is 2.2.7a,  on Solaris 8
>> >>Printers are HP printers - e.g. HP 8100dn
>> >>
>> >>All clients including 95/98 were happily printing on a very much older
>> >> of Samba (2.0.6)
>> >>
>> >>printing directly from Unix to the printer is working ok
>> >>
>> >>Has anyone experienced this problem or have any advice on how to
>> >>get my older boxes printing with the latest Samba?
>> >>
>> >>any thoughts welcome - no really - anything - please....
>> >>:-)
>> >>
>> >>-peter.
>> >>
>> >>
>> >>(p.s. Just for a wild stab in the dark I tried setting the "disable
>> >> yes"
>> >>but this stopped all printing from making it to the computer - even
>> >>clients that
>> >>were originally working.)
>> >>
>> >>
>> >>relevant bits of conf. file included below...
>> >>note that I don't have print command explicitly stated, but testparm
>> >>indicates that it is configured properly...
>> >>
>> >>[global]
>> >>  printing = sysv
>> >> lprm command = /usr/bin/cancel %p-%j
>> >> lppause command = lp -i %p-%j -H hold
>> >> lpresume command = lp -i %p-%j -H resume
>> >> load printers = no
>> >>
>> >>[hp8100DN1]
>> >> printer = hp8100dn_1
>> >>comment = HP LaserJet hp8100 DN
>> >>path = /var/spool/lp/tmp/samba
>> >>guest account = nobody
>> >>guest ok = yes
>> >>browseable = yes
>> >>printable = yes
>> >>writable = yes

Opinions contained in this e-mail do not necessarily reflect
the opinions of the Queensland Department of Main Roads,
Queensland Transport or National Transport Secretariat, or
endorsed organisations utilising the same infrastructure.
If you have received this electronic mail message in error,
please immediately notify the sender and delete the message
from your computer.

More information about the samba mailing list