[Samba] Can't write to a samba share...

Brad sambauser at sportingwheelies.org.au
Mon Mar 10 07:28:21 GMT 2003

I have a Red Hat 8.0 PC with a scanner connected and I am scanning images with 
sane. I would like to store the scanned images on a Red Hat 7.3 file server 
using Samba, but I am having some difficulty understanding how the file and 
directory security preferences work.

I can attach to the share (called "Shared") with:

smbmount //server/Shared /mnt/S -o username=username%password

and can read the contents with no problems. When I do this as root on the 
scanner workstation, I can write to it with no problems. However, when I log 
in on the scanner workstation as a regular user (ie not root), I cannot write 
to the remote share. If I manually log in to the Server as the username and 
password, I can write to the shared directory OK. 

If I do an ls -ls of S from within the /mnt directory, I get:

4 drwxr-xr-x    1 root     root         4096 Mar 10  2003 S

so it is clearly not writable by the user.

Here is the server smb.conf settings:

        workgroup = WORKGROUP
        server string = Samba Server
        log level = 2
        log file = /var/log/samba/log.%m

        comment = Shared Directories
        path = /home/Shared
        valid users = @users
        writable = true
        force group = users
        force directory mode = 770
        inherit permissions = yes
The workstation username has a valid login on the server and is part of the 
"users" group. I have tried to add "-o rw" to the smbmount command, but it is 
still the same. I have then added "write list = @users" to the "Shared" share 
settings in the server smb.conf file, but I still can't write to it.

I have increased the server smb.conf log level to 4 and then done a "touch 
/mnt/S/test" on the scanner workstation and have looked at 
/var/log/samba/scannerworkstationname on the server and  and this is what it 

[2003/03/10 17:18:11, 3] smbd/process.c:process_smb(860)
  Transaction 40 of length 84
[2003/03/10 17:18:11, 3] smbd/process.c:switch_message(667)
  switch message SMBtrans2 (pid 13071)
[2003/03/10 17:18:11, 4] smbd/uid.c:change_to_user(118)
  change_to_user: Skipping user change - already user
[2003/03/10 17:18:11, 3] smbd/trans2.c:call_trans2qfilepathinfo(1615)
  call_trans2qfilepathinfo: TRANSACT2_QPATHINFO: level = 1
[2003/03/10 17:18:11, 3] lib/util.c:unix_clean_name(387)
  unix_clean_name [/rr]
[2003/03/10 17:18:11, 3] lib/util.c:unix_clean_name(387)
  unix_clean_name [rr]
[2003/03/10 17:18:11, 3] smbd/trans2.c:call_trans2qfilepathinfo(1636)
  call_trans2qfilepathinfo: vfs_stat of rr failed (No such file or directory)
[2003/03/10 17:18:11, 3] smbd/error.c:error_packet(91)
  error string = No such file or directory
[2003/03/10 17:18:11, 3] smbd/error.c:error_packet(115)
  error packet at smbd/trans2.c(1638) cmd=50 (SMBtrans2) eclass=1 ecode=2

Does anyone have any ideas why this is happening?


More information about the samba mailing list